Upgrading server to latest specs for v8 - will legacy sites break?

Permalink
Hello,
I have a bunch of legacy sites running on my managed VPS (5.6.xx) and I want to upgrade/make server compliant to be able to install latest versions of C5.

Has anyone done this and...will the old sites 'break' in any way - if so is there any workaround to allow this to happen (rather than having to host/ pay for two servers)
Thank you in advance.

splashby
View Replies:
JohntheFish replied on at Permalink Reply
JohntheFish
The main obstacle is php versions. For v8 you can take advantage of php7+, typically php7.2.
For legacy c5.6 sites, you are stuck with <=php5.6, unless you update the sites to c5.6.4.0.

c5.6.4.0 is a pretty safe update for legacy sites as long as you go through 5.6.3.5 first. You need to run this update before switching php to php7.2. The main obstacles are likely to be some addons or custom application code that are not compatible with php7.2, so be prepared to make some small (or larger) code changes depending on what happens.

Making a development clone to test the update is the safest route, depending on how critical site continuity is.
splashby replied on at Permalink Reply
splashby
Hello Again (John),

I have encountered a situation where the software will not update past 5.6.3.5 on several applications...states ' Your site is already up to date'.

Any thoughts or 'workarounds' on this?
Thanks again.
JohntheFish replied on at Permalink Reply
JohntheFish
5.6.3.5 is the last automated update for legacy sites. For 5.6.4.0, you need to download the zip and do a manual update.
splashby replied on at Permalink Reply
splashby
Thanks again. That explains it. Cheers for taking the time.
splashby replied on at Permalink Reply
splashby
Thank you for your response. That's very helpful and much appreciated.