Warning: imagejpeg() [function.imagejpeg]: Unable to open

Permalink
I'm migrating a site and keep getting this error on some pages. Mainly the pages using the Dojo page filter, but not always.

Warning: imagejpeg() [function.imagejpeg]: Unable to open '/home/SITENAME/public_html/files/cache/052f225905c1618003df0c5088aec7a9.jpg' for writing: Permission denied in /home/SITENAME/public_html/concrete/helpers/image.php on line 172

I've tried changing the permissions on the files folder to 755 and applied to enclosed folder but still no luck?

Any ideas?

I'm running 5.4.2.2 if it helps.

View Replies: View Best Answer
CreativeLabel replied on at Permalink Reply
If anyone can shed some light on this it would be helpful? I'll will post my solution up if I get any further.
noXstyle replied on at Permalink Reply
noXstyle
There is absolutely no need to take cache when migrating a site.

I would suggest that you delete all the cache files. In case you don't want to recursively chmodding the cache dir to 777 should grant the actual permissions.
CreativeLabel replied on at Permalink Reply
Thanks noXstyle, I'll take a look later and see if that makes a difference.
CreativeLabel replied on at Permalink Reply
Ok this is really strange. I emptied the cache directory and still no luck, and if I change the permissions on the cache folder then I get another error and I can't use the site at all:

Warning: require_once(Zend/Cache/Backend/File.php) [function.require-once]: failed to open stream: No such file or directory in /home/MYACCOUNT/public_html/concrete/libraries/3rdparty/Zend/Cache.php on line 133

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Cache/Backend/File.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/owen/php') in /home/MYACCOUNT/public_html/concrete/libraries/3rdparty/Zend/Cache.php on line 133

I don't get it? I've never had this problem before.
hostco replied on at Permalink Reply
hostco
Change the permissions on the /files directory to 777 as well as all of the directories inside of it.
CreativeLabel replied on at Permalink Reply
I've tried that, and it's fine on the files folder alone but if it I do it to all folders in the files directory then the Require once error above appears?
CreativeLabel replied on at Permalink Reply
OK this is getting pretty urgent. I guess I could hard code the include path but I'm not 100% sure where it is and what to change it too?
CreativeLabel replied on at Permalink Reply
So I've tried to do a fresh install in a sub-directory hoping that Concrete might set the permissions itself, but no luck. If I change the permissions on the config, packages and files folder the require_once error appears straight away, which confuses me a little as to how I installed concrete on the hosting in the first place.
CreativeLabel replied on at Permalink Best Answer Reply
For future reference the problem was the PHP handler. It has been changed to CGI mode (as opposed to DSO) and turned suEXEC ‘off’ - might be useful for someone down the line.
ksturman replied on at Permalink Reply
what file is the php handler in and what do I need to change? Please help!
CreativeLabel replied on at Permalink Reply
Hi Ksturman,

I didn't actually so this, the person who looks after my server did. I think this is server settings not something you can just change in the concrete5 file system. Hopefully someone else can give some insite into how to do this.