5.5.2 and "Task Permissions"

I am having a devil of a time getting "task permissions" to work on Concrete 5.5.2.

As the Admin user I have added one user to the site and placed them in a new group named "Editors". I click on Dashboard->System & Settings->Task Permissions and then click the "Add Group" button and select the Editors group. So far so good.

The problem arises when I try to change any of the "No" entries to "Yes". Every time I change some of the entries to "Yes" and then click Save all of the entries revert back to "No".

I have advance permissions enabled.

Does anyone know what I am doing wrong?

Thanks in advance.

View Replies: View Best Answer
andrew replied on at Permalink Best Answer Reply
I think this is a problem with the radio input button on that page. Try upgrading to It is a low-risk upgrade that should fix this problem.
roarkh replied on at Permalink Reply
I think you may be right, it looks like the permissions may have taken affect even though the radial boxes were staying set at "No".

I will apply that update later today.

Thank you.
ScottC replied on at Permalink Reply
Andrew is right. The radio buttons were screwed up and the new update does indeed update the task permissions in the database and in the UI. I marked this as best answer.
spjuphigh replied on at Permalink Reply
I updated to and it did fix the radio button issue, but it didn't actually change the permissions. I tried to allow a specific group to access the sitemap, user and group searches. The radio buttons show those permissions as granted, but, when I sign in as one of the users in that group, there's no access to those functions. I've cleared - and disabled - the cache, signed in and out as both that user and as admin, I even rebooted my computer. Nothing.

Any ideas?
andrew replied on at Permalink Reply
That's odd. When I add a group using to the task permissions page and change the permissions on a few items to "Yes" for that group, they do indeed save.
tek01 replied on at Permalink Reply
I had issues similar to spjuphigh. My editors group could not modify stacks. Found out that the problem was in the full sitemap permissions (and not in the "Task Permissions" page): solved giving to my editors group view/edit permissions for Dashboard->Stacks & Blocks page in the full sitemap (with system pages checked). My problem was solved this way (in 5.5.2).
wjosephson replied on at Permalink Reply
I followed teko's advice for granting access to Sitemap and it does work.

However the user group now has access to the entire Dashboard even though I did not grant that permission. Within the Dashboard the user group has permission to edit/delete/add users which was not my intent.