Advanced Permissions: Composer/Write: Custom attributes missing for user group

Permalink
I am setting up a user group to be able to create and edit blog posts, usinghttp://skybluesofa.com/blog/configuring-concrete5-composer-advanced... as a guide. However, when the "blogger" group tries to create a new post, the custom attributes I set up are missing (Basic Information, title, thumbnail, meta, tags, etc). They only see the main body block.

Any thoughts about which setting I need to change to fix this issue?

View Replies: View Best Answer
enlil replied on at Permalink Reply
enlil
If I'm not mistaken, what you need to do is go to page types, and enable those attributes on that page type for them to begin showing in the composer edit interface.

EDIT: Also be sure you gave those users proper permissions to edit the attributes.
leviticus replied on at Permalink Reply
I guess I should have been more clear. I have enabled the attributes on the Page Type and can see them when I compose/write as an Administrator. It's just the Blogger user group that is unable to see the attributes on the write screen.

EDIT: Where do I set permissions on the attributes? I can't seem to find which screen houses those.
enlil replied on at Permalink Best Answer Reply
enlil
Take a look at the permissions on the page type defaults page. Then in turn, make sure you also set permissions on the page the blog entries will go under to "inherit permissions from page type defaults. On a side note to the second part of that process, you may need to manually set blog entries to inherit permissions if they are pre existing pages after getting set up.
leviticus replied on at Permalink Reply
Thank you for pointing me in the right direction.

In case anyone else has this same issue, I found the correct spot to change the permissions under Sitemap > Dashboard > Pages & Themes > Page Types > Attributes. I never would have thought to look there. I had set the blogger user group not to be able to edit/view Pages & Themes, so the Attributes were inheriting that setting. Changing the permissions on just Attributes to allow the blogger group fixed the issue.

Thanks again!