Beginner - Setting page properties - Exclude from Nav

Permalink 1 user found helpful
In a new install of Concrete5 version, I am trying to exclude some pages from Auto-Nav. In dashboard, I go to Page Properties > Custom Attributes. I see a list of All Attributes, but no Selected Attributes. How do I get a checkbox for excluding nav to appear in Selected Attributes?

More generally, how do I get attributes to appear in Selected Attributes?

View Replies: View Best Answer
Steevb replied on at Permalink Reply
Click on attribute in left column.

It will appear in right column.

Click check box 'Yes' and save.

All other attributes are the same.
wrmoyer replied on at Permalink Reply
When I click on the attribute on the left, nothing happens. To the left of each item under "Navigation and Indexing" I see a tiny icon that contains a question mark and exclamation point.

Under "Page Header", the items have to their left a small icon that looks like a message.

Rolling the cursor over any item highlights it in blue, and causes a small message in the lower left of the screen "javascript:void(0)".

Is this correctable? ... or reinstall Concrete5?
Steevb replied on at Permalink Reply
Something is wrong with your set up.

Clicking any attribute should send it over to the right column.

Can you add 'Custom Attributes' from within pages of your website?

Meaning, for example, on home page in edit mode hovering over edit then clicking 'Properties' then 'Custom Attributes'. Can you then assign 'Exclude From Nav'?
wrmoyer replied on at Permalink Reply
Something is definitely wrong with my setup. Accessing 'Custom Attributes' from within a website page leads to exactly the same result as doing it from the sitemap. I changed the theme to plain yogurt ... still same problem
So far, all else seems to work.
wrmoyer replied on at Permalink Reply
Any thoughts as to where I would look for the problem? Is there a way to reinstall Concrete5 over top of the existing website so that I do not lose work done to date? .. like a refresh/repair of the inner works?
wrmoyer replied on at Permalink Best Answer Reply
Problem solved. It was a bad theme that corrupted the database for all future themes.
Anticept replied on at Permalink Reply

I know this is an old topic, but I wanted to put this here incase someone stumbles upon it in the future.

I also was having an issue where the page properties dialog was not loading completely, and the save button was nowhere to be found.

The issue I had was that I originally made the site with another theme, and moved to a new one. The old theme had a custom page type which I was using.

To rectify the problem, I only needed to select a new page type in the design view (can be done from the sitemap or on the page) and the properties dialog was fixed.
bcarvalho replied on at Permalink Reply
This is exactly the problem that I am having – down to the descriptions of the icons that I see in the properties window. Here is my post with screen pictures:

However, I don't think the problem is a bad theme, per se. If anyone else has any other info on this issue, please post.
wrmoyer replied on at Permalink Reply
My process to debug was this:
1) Start with new install of concrete5. Set theme as plain yogurt. At this point everything worked - page attributes and all.
2) Export the database to SQL text file for base reference.
3) Download and Install the theme <theme name>. Symptoms appear as you have also seen - problems with page attributes.
4) Change theme back to plain yogurt, uninstall and remove <theme name>. Problem still remains with page attributes.
5) Export database to SQL text file.
6) Use Microsoft Word to compare the before and after SQL text files to find out what the difference is between the two "documents." Word compares and produces a 'merged' document noting the differences using red font with strikeouts and additions to show the differences. (With thousands of lines to compare, Word is really a lifesaver here.)

In my case, this process showed that <theme name> still had a key defined in table "AttributeKeys" that did not exist in the virgin database. Removing that line from the SQL database using phpMyAdmin webhosting utility cured the problem for me.

I was flying blind - and have no deep knowledge of SQL or databases - I was trying to find out what the heck had changed in the process. In my case it was definitely a quirky theme that did not completely clean up upon removal.

Please let me know what you find when you solve your issue.
bcarvalho replied on at Permalink Reply

For a guy that does not know SQL and was flying blind, you sure were resourceful. Thanks for sharing, and now this stays up here for people to find through searches.

In my case it becomes a bit hard to do because our site is live and pretty huge. But I'll forward this to a programmer that is helping us and maybe he can take a look at AttributeKeys and fuss around in the databases.

Thanks wrmoyer!
wrmoyer replied on at Permalink Reply
Hi bcarvalho. Since a programmer may look at the issue, let me forward some additional information.

I was not sleeping well having deleted a record whose function I did not know from a complex database - so I went back at the issue. I installed a new Concrete5 and the problematic theme. Predictably the problem with page properties returned. Using phpMyAdmin, I opened up the database and examined the records in 'AttributeKeys'. Instead of deleting the bad record, I used the database editor to see if the bad record was glaringly different from other similar records related to the theme. It was! The bad record had a check in the box under 'NULL' and a blank 'VALUE' for 'atID'. To make it look like its neighbor records, I unchecked the 'NULL' box and put a '2' in the 'VALUE' field. Viola! Problem cured *AND* I am sleeping better.

I have the same issue as you with a production website that can not be taken down, so I purchased an inexpensive domain and associated it with the same instance of the host server and built a separate Concrete5 "tree" to test with.
bcarvalho replied on at Permalink Reply 1 Attachment

I think you are right on the money. I just upgraded to Concrete5 v. and though the problem continues, it now has a much better error report. In the Page Properties window it states:

Fatal error: Call to a member function getAttributeKeyID() on a non-object in /var/www/vhosts/ on line 65

(I also attached a screen picture). Notice that the problem is in the AttributeKeyID. I am going to have a look in there and see if, like you, I can find something that is obviously set incorrectly. I'll post any results here.

Thanks so much William.
kranthikumar replied on at Permalink Reply
Hi bcarvalho,

Me too got this same error like SAVE button is not displaying in Page Properties,

i found reason and clear it,

i install one package in that i created some attributes because of this package i got that error, i uninstall that package but error is not solved, i just go to Database and find search for records in all tables like "%phub videos%"(my package name is phub videos ) i find it in min 7 or 8 tables and then i deleted all rows ,

Know Every think is working good,
I think no need to change in themes or re install c5 again, what we did previous then just rollback all steps then it's solve.

I hope that it may be useful,

Thank you.
bcarvalho replied on at Permalink Reply

Thank you for the information. Unfortunately this did not happen after I installed any external software, it happened after I upgraded to the last version of Concrete5, so I wouldn't know what to look for in the tables.

If anyone has other ideas, please let me know!