C5 Menu not showing

Permalink
Hello, all. I'm pretty new to the whole Concrete business - I'm working on my first very own theme. For the life of me, I can't figure out why my menu bar isn't showing up. When I navigate to domain.com/index.php/login I can sign in, and it redirects me back to my home page, but the top menu bar isn't showing. I have placed this code instead of my title tag:

<?php Loader::element('header_required'); ?>


yet still, it doesn't show. Does anyone have a reason that it might not be there?

Thanks in advance!

Cheers

urbandesign
View Replies: View Best Answer
cannonf700 replied on at Permalink Reply
cannonf700
It could be a couple of things... can you post the rest of your code (everything in the <head> area.
here is what a typical header.php looks like for me:
[code]
<?php defined('C5_EXECUTE') or die(_("Access Denied.")); ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html lang="en-US" xml:lang="en-US" xmlns="http://www.w3.org/1999/xhtml">

<head>
<!-- Site Header Content //-->

<link rel="stylesheet" media="screen" type="text/css" href="<?php echo $this->getStyleSheet('main.css')?>" />
<link rel="stylesheet" media="screen" type="text/css" href="<?php echo $this->getStyleSheet('typography.css')?>" />
<!--[if IE 6]>
<link rel="stylesheet" type="text/css" href="iecss.css" />
<![endif]-->

<?php
Loader::element('header_required');
?>

</head>[code]
If you are using javascript make sure to place the script codes UNDER the call for the 'header_required'.
urbandesign replied on at Permalink Reply
urbandesign
Sure thing - here she is.

<!doctype html>
<!--[if lt IE 7 ]> <html class="no-js ie6" lang="en"> <![endif]-->
<!--[if IE 7 ]>    <html class="no-js ie7" lang="en"> <![endif]-->
<!--[if IE 8 ]>    <html class="no-js ie8" lang="en"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--> <html class="no-js" lang="en"> <!--<![endif]-->
<head>
  <meta charset="utf-8">
  <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<?php Loader::element('header_required'); ?>
  <meta name="description" content="">
  <meta name="author" content="">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <link rel="shortcut icon" href="<?=$this->getThemePath()?>/favicon.ico">
  <link rel="apple-touch-icon" href="<?=$this->getThemePath()?>/apple-touch-icon.png">
  <link rel="stylesheet" href="<?=$this->getThemePath()?>/css/style.css?v=2">


Could it have something to do with HTML5?
cannonf700 replied on at Permalink Best Answer Reply
cannonf700
Okay,
make sure you include this as the very first thing:
<?php  defined('C5_EXECUTE') or die(_("Access Denied.")); ?>


Then replace every use of this:
<?=$this->getThemePath()?>

with this:
<?php echo $this->getThemePath(); ?>


then put
<?php  Loader::element('header_required'); ?>

BELOW your stylesheet and theme path calls. just above your call for javascript
urbandesign replied on at Permalink Reply
urbandesign
Okay, I followed your instruction, and my head looks like this:

<?php  defined('C5_EXECUTE') or die(_("Access Denied.")); ?>
<!doctype html>
<!--[if lt IE 7 ]> <html class="no-js ie6" lang="en"> <![endif]-->
<!--[if IE 7 ]>    <html class="no-js ie7" lang="en"> <![endif]-->
<!--[if IE 8 ]>    <html class="no-js ie8" lang="en"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--> <html class="no-js" lang="en"> <!--<![endif]-->
<head>
   <meta charset="utf-8">
   <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
   <meta name="description" content="">
   <meta name="author" content="">
   <meta name="viewport" content="width=device-width, initial-scale=1.0">
   <link rel="shortcut icon" href="<?php echo $this->getThemePath(); ?>/favicon.ico">
   <link rel="apple-touch-icon" href="<?php echo $this->getThemePath(); ?>/apple-touch-icon.png">
   <link rel="stylesheet" href="<?php echo $this->getThemePath(); ?>/css/style.css?v=2">


but it's still not working... the css and js is working no problem, but the menu bar is still not showing up.
cannonf700 replied on at Permalink Reply
cannonf700
I'm not super familiar with html5 but it looks like you still need an <html> tag in the header and the footer.
this is the documentation takes from http://www.w3schools.com/html5/tag_doctype.asp. you can see that you will need that <html> tag in the header and then again at the end of the document.
<!DOCTYPE HTML>
<html>
<head>
<title>Title of the document</title>
</head>
<body>
The content of the document......
</body>
</html>
burbleweb replied on at Permalink Reply
may have no bearing on your issue but I have just had this problem. My issue was all worked fine, but I couldnt enable SEF URLS as I was getting a well documented no input specified warning.

I then put in a fix as per some posts elsewhere of placing:

cgi.fix_pathinfo = 0

within the site.php file.

Then on logging into the website I now get SEF urls but I cant see the dashboard top menu system. However I am clearly logged in as my margins at the page header are increased and I can type in the dashboard URL and load that up
altef replied on at Permalink Reply
altef
I had to add <?php Loader::element('footer_required'); ?> to the bottom to get the menu to show up
davidofadelaide replied on at Permalink Reply
davidofadelaide
Thanks, I was having same issue, and it wasn't until I added in the Footer required that I got it to come up also.