Can't Edit Blocks - ccm-highlighter Not Working

Permalink 1 user found helpful
I am currently not able to edit or add any blocks to a site. The custom theme is using quite a few jQuery and javascripts and I am assuming they are conflicting with the block editing function, because the ccm-highlighter doesn't even show up in the source code when I click on the block, whereas if I switch to Greek Yogurt, I can see that it is being added to the output source code.

However, I am not able to determine how to fix this.

The theme's scripts are added to the bottom of the footer, after the footer_required code, as it breaks the theme if they are called before it.

I've tried de-activating the scripts when in edit mode. Here is a copy of the footer:

<?php  defined('C5_EXECUTE') or die("Access Denied."); ?>
<footer>
  <p id="copyright">©<?php echo date("Y"); ?> NIS-Foundation. All Rights Reserved.</p>
  <p id="altnav"><a href="<?php echo DIR_REL?>/alt-pages/disclaimer" title="Disclaimer">Disclaimer</a><span>|</span><a href="mailto:[email protected]" title="Contact Us">Contact Us</a></p>
  <div class="footer-right">
    <?php
   $a = new GlobalArea('Footer Right');
   $a->display($c);
?>
  </div>
</footer>
<!-- end footer -->
</div>
<!--end wrapper -->
<?php  Loader::element('footer_required'); ?>


but if I try to deactivate them all, the entire site goes blank, as this particular theme is unfortunately dependent on all these scripts. This was a client request to have the site use all this parallax scrolling functionality but a static version of it does work.

I've also tried implementing it in a Concrete 5.7 version and that is even worse so I went back to 5.6 and at least the theme works when not in Edit mode.

How can I get the blocks to be editable?

sherri333
View Replies:
sherri333 replied on at Permalink Reply
sherri333
I ended up resolving the problem by examining which scripts seemed to be giving errors (in the browser console) and sequentially disabling them during edit mode. That, and a few edit mode CSS styles and it finally worked.

Am posting this follow up reply in case any one else runs into the same problem.

Overall, this custom theme has quite a few jQuery and javascripts, so its no wonder there was a script collision.