can't get update 5.7.5.3

Permalink
EDIT
tried again and I got this

An error occurred while downloading the package.
Check For Updates

Version 5.7.5.3

Update Ready

Now it says update ready but also there was an error so not if I have it or not

I'll try to install it and see

OK installed

Upgrade to 5.7.5.3 complete!

I think it's ok because the google map shows no issue now, whereas previously it would have shown error.

END EDIT


I'm using 5.7.5.2 Elemental theme, bare bones test site.

Cannot update to 5.7.5.3

When I go dashboard update concrete5 I get this page with download link

Available Update for Download
Version: 5.7.5.3. Release Date: November 24, 2015


but when I click download link, I get 'waiting for myhost.com' and it just hangs there. Nothing happens. No download.

Finally I get this in the browser

An exception occurred while executing 'select bID, arHandle, issID from CollectionVersionBlockStyles where cID = ? and cvID = ? and issID > 0' with params ["125", "1"]: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away


Do I need to perform some configuration anywhere to get updates because at this point I haven't done anything?

Site works perfectly otherwise.

How else can I get the latest update?

LT

lowtech
View Replies:
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi lowtech,

You can check your current concrete5 version on the Environment Information page.
Dashboard > System & Settings > Environment > Environment Information
lowtech replied on at Permalink Reply
lowtech
Hi MrKD

That's great.

Yeh it seems ok

# concrete5 Version
Core Version - 5.7.5.3
Version Installed - 5.7.5.3
Database Version - 20150731000000


I don't know what caused the hang up in the first place, but after trying several times and it just hanging. Then deciding to post issue. And after posting I casually retried, it worked. Go figure:-)

Thanks

LT
huge replied on at Permalink Reply
same problem :(

# concrete5 Version
Core Version - 5.7.5.3
Version Installed - 5.7.5.3
Database Version - 20150731000000

# concrete5 Packages
None

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Microsoft-IIS/8.0

# Server API
cgi-fcgi

# PHP Version
5.5.29

# PHP Extensions
bcmath, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, mysqlnd, odbc, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, Reflection, session, SimpleXML, soap, SPL, standard, tidy, tokenizer, wddx, wincache, xml, xmlreader, xmlrpc, xmlwriter, Zend OPcache, zip, zlib.

# PHP Settings
max_execution_time - 300
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 90
max_input_vars - 1000
memory_limit - 128M
post_max_size - 20M
sql.safe_mode - Off
upload_max_filesize - 30M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
odbc.max_links - Unlimited
odbc.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 1440
soap.wsdl_cache_limit - 5
wincache.maxfilesize - 256
wincache.ttlmax - 1200
opcache.max_accelerated_files - 4000
opcache.max_file_size - 10240
opcache.max_wasted_percentage - 5
MrKDilkington replied on at Permalink Reply
MrKDilkington
@huge

An alternative approach is updating concrete5 manually.

"How to manually upgrade concrete5 (5.7)"
http://documentation.concrete5.org/tutorials/how-to-manually-upgrad...
huge replied on at Permalink Reply
thanks, I'm going to try this.

But do I need to delete the "concrete5.7.5.3_remote_updater" folder under \updates when I manually install the new version?
huge replied on at Permalink Reply
I completed the upgrade using the manual procedure :)
I removed the old upgrade folder, and also removed the related entry from application\config\update.php

it seems all ok
thanks
# concrete5 Version
Core Version - 5.7.5.6
Version Installed - 5.7.5.6
Database Version - 20151221000000