Can't update v to v8.5.4

first: my english is not so good, but i will try my best.
second: i have taken over (inherited) this projekt and i am not the creator of the site.
third: the system has done an "automatic" update in february 2020 and the site was broken than. the provider DomainFactory restored the Database and Web-Folder after the "automatic" update and since then there are some problems, but somehow the site is running. i know that some tables are not "complete"? i checked some in february.

now i tried to update from to v8 and after 10 days i am still at the start and hope you can help, otherwise i don't know what to do.
Running the site like is is not possible, because DomainFactory is going to switch of PHP <7.2. when i switch the domain to PHP 7.2, the site is also broken.

Now my upgrade-process.

1. Site works and this is the Siteinfo:
# concrete5 Version
Core Version -
Version Installed -
Database Version - 20160615000000

# concrete5 Packages
Easy Image Slider (1.0.1), Table Block (0.9.5)

# concrete5 Overrides
Here are many urls ike "blocks/downloads_block/editmask.php" or "themes/clientName/image/nameOfCustomer.png". Don't know if the data is to private or needed to help me

# concrete5 Cache Settings
Block Cache - Off
Overrides Cache - Off
Full Page Caching - Off
Full Page Cache Lifetime - Every 90 minutes.

# Server Software

# Server API

# PHP Version

# PHP Extensions
bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dba, dom, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, json, libxml, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcntl, pcre, PDO, pdo_mysql, pdo_sqlite, pgsql, Phar, posix, Reflection, session, SimpleXML, soap, SPL, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zip, zlib

# PHP Settings
max_execution_time - 180
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - -1
max_input_vars - 1000
memory_limit - 100M
post_max_size - 8M
sql.safe_mode - Off
upload_max_filesize - 8M
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pgsql.max_links - Unlimited
pgsql.max_persistent - Unlimited
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 1440
soap.wsdl_cache_limit - 5

2. Symlink because of multiple instances
I have 3 Instances (Sites) of Concrete 5 CMS. So i use one Folder "Conrete5Core" and have 3 Folders. One each Site. The reason is, that i don't have to manage blocks&similar for each site individually, because same client.
From this folders i have a Symlink to the Core-Concrete-Folder like "concrete5-8.5.4". so long this settings are working for "concrete--" at the time.

3. Copying concrete 8.5.4 into concrete-Folder on Core
Now i put the folder "concrete5-8.5.4" into the "concrete5core/updates/" - folder and change the symlink to the new Version. The Updatefolder is recognized from the system and i klick on "Aktualisierung installieren" (picture)

than it stops the installing an i get errors like this:
-The DQL alias 'r' contains an entity of an inheritance hierarchy with an empty discriminator value. This means that the database contains inconsistent data with an empty discriminator value in a table row.

-An exception occurred while executing 'ALTER TABLE atSelectedTopics ADD avTreeTopicNodeID INT UNSIGNED AUTO_INCREMENT NOT NULL, ADD treeNodeID INT UNSIGNED NOT NULL, DROP TopicNodeID, CHANGE avID avID INT UNSIGNED DEFAULT NULL': SQLSTATE[42000]: Syntax error or access violation: 1075 Incorrect table definition; there can be only one auto column and it must be defined as a key


in the last 10 days i tried many issues. i don't know all at the time. But change folder proxies to old files, take the database before the update and have edited some php-files recommendet.
and the other question is, can up update with php 7.0.32 to version 8.5.4 and switch than to php 7.3?

sorry for my bad englisch. hope u can help me. my last chance. thx

1 Attachment

View Replies:
websonic replied on at Permalink Reply
no help?

i think the Problem are the database-Tablets. In February 2020 the site updated manually somehow to 8.x. The Domain Factory Restored the Database and the webfolder, but somehow some tables were "broken". since then the site works, but now and then with some errors. is there a way to repair the tables, without loosing the conctent?

my though was to install a new 8.5.4 instance of concrete 5 and then somehow to put the content and blocks, etc to this new instance. but i don't know if it works