Disqus Comment Count Not Displaying (Random Posts)

Permalink
Hi There,

I am working on a site at the moment (Concrete version 5.6.3.2) and have the Disqus block installed. The block itself works completely fine, however I am having issues with getting the actual comment count to work on the blog index page.

I have basically adapted the default blog index template and added the following code so it echo's with each blog post:

<a href="<?php  echo $nh->getLinkToCollection($cobj)?>#disqus_thread"></a>


For the most part, this works fine however it randomly fails to echo the link text (though the correct <a> tag is present in the source - I have attached a screenshot from Firebug to help explain).

I have tried to find out why this happens randomly - even making a word for word duplicate of a "working" post can sometimes fail. I am at a complete loss of what to do next and was wondering if anyone else had any suggestions/solutions on where to go from here. Has anyone also experienced the same issue on their site and found a way to fix this?

The site isn't online so I cant give you any URL's unfortunately. I am also using Composer for my blog posts by the way.

Many thanks in advance!

1 Attachment

View Replies:
Nanco replied on at Permalink Reply
Just wanted to update this post for anyone who comes across this problem.

After establishing that changing the coding on my site/templates wasn't working, I decided to check the Disqus admin control panel. Everything "appeared" to be okay in there, however I decided to delete the site record in there and then re-add it from scratch just to be on the safe side.

I have since performed checks on the posts/comment counts on my site and have experienced no problems. The posts that previously didn't work still don't have a comment count with them, however all new posts have a comment counter which updates correctly (fingers crossed).

The only potential thing I can think of that may have contributed to this problem in the end is that I entered the live site address in the Disqus admin control panel. The only different thing I did this time was enter the localhost directory where my offline site was located.

Hopefully this is the solution, however I will update this if I figure anything else out in the meantime.