E-mail submitted form is empty

Permalink
Hello guys,


When people submit a form is it send to some e-mail addresses so people don't need to login on the website to see the results. But since the latest patch these e-mails are blank. Only the form labels are shown, the submitted content is missing.

I'm running a few websites with Concrete5 and they all doing the same thing since the latest patch.

View Replies:
splashby replied on at Permalink Reply
splashby
I am running into the same issues, so will be interested to see how this unfolds.
graphiczweb replied on at Permalink Reply
graphiczweb
I have the same problem. I can manage the site but do not have the core knowledge of Concrete5 to unravel a solution. Can anyone give me a hand? What info do you need?
Thanks - very grateful
LudoHH replied on at Permalink Reply
Hi,

I've also the exact same problem. Anyone knows how to solve this?
Thanks in advance,
Byrge
dexterweb replied on at Permalink Reply
dexterweb
Hey Guys,

I was having the same issue and solved it.
In my case I've made a Form block override for some custom stuff (root/blocks).
Apparently since the last concrete5 update this issue occurred.
So I took the Form block of the latest concrete5 update (root/updates/concrete5.6.3.1_updater/concrete/blocks) and replaced it with the one I've overritten in root/blocks. And I was good to go!

Hope this will solve your issue as well.

Cheers!
LudoHH replied on at Permalink Reply
Hi, this works. Thanks for your reply.
JohntheFish replied on at Permalink Reply
JohntheFish
Have any of you submitted a bug report?
http://www.concrete5.org/developers/bugs/5-6-3-1/...
LudoHH replied on at Permalink Reply
Hi, no I didn't report this as a bug.
iumeo replied on at Permalink Reply
Hi,

I also occured this error.
I fixed it by update the following file in concrete 5.6.3.1 :
\concrete\mail\block_form_submission.php

The line 6 is wrong :
$submittedData .= $questionAnswerPair['question']."\r\n".$questionAnswerPair['answerDisplay']."\r\n"."\r\n";

must be updated by :
$submittedData .= $questionAnswerPair['question']."\r\n".$questionAnswerPair['answer']."\r\n"."\r\n";

Don't forget to override it with the standards rules of C5.
It works right now for me ;)

Best regards,
splashby replied on at Permalink Reply
splashby
I went ahead and submitted a bug report. Thanks
Remo replied on at Permalink Reply
Remo
This is his bug reporthttp://www.concrete5.org/index.php?cID=643206&editmode=...

Unfortunately, I can't reproduce it.. If anyone could let me know what I'm missing, I'd be happy to fix it
iumeo replied on at Permalink Reply
I don't know exactly how this bug appears but my form controller is overrided.
I don"t know if it helped...
Remo replied on at Permalink Reply
Remo
If you're using an overridden controller, it makes sense. The variable wasn't there and thus doesn't match the mail template, but I definitely can't see the problem in 5.6.3.1..
splashby replied on at Permalink Reply
splashby
Thanks for responding. In my case the website (Gardenblueprints.net) was the one I had an issue with - have I removed the form for the time being. What else do you need to know? Thanks.
Remo replied on at Permalink Reply
Remo
I'd need the environment information for the site where you had the problem. And the if it's <5.6.3.1, you might have to update it because we don't fix problems for 5.5.2.1 anymore..
splashby replied on at Permalink Reply
splashby
Just updated - same issue:

gardenblueprints.net (pls let me know if you need access to backend)

Thanks, Michael

# concrete5 Version
5.6.3.1

# concrete5 Packages
AddThis (1.0), Amiant Image Gallery (0.7.3.1), CorporateAmerica Theme (1.5.1), Facebook Like Button (1.1), Featured Content Slider (1.1), Free Cookies Disclosure (1.0.3), Gallery (1.8.1), Lightboxed Image (0.9.2), Simple Facebook Gallery (1.03), Simple Image Gallery (1.1.3), Slate Theme (1.4), Sortable Fancybox Gallery (1.17), ViewPort (0.9.1).

# concrete5 Overrides
mail/block_form_submission.php

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - Off
Full Page Caching - On - In all cases.
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache

# Server API
cgi-fcgi

# PHP Version
5.3.23

# PHP Extensions
bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, filter, ftp, gd, hash, iconv, imap, ionCube Loader, json, libxml, mbstring, mcrypt, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, Reflection, session, SimpleXML, soap, sockets, SPL, SQLite, sqlite3, standard, tokenizer, xml, xmlreader, xmlwriter, zip, zlib.

# PHP Settings
max_execution_time - 60
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 82M
post_max_size - 82M
safe_mode - Off
safe_mode_exec_dir - /usr/local/php/bin
safe_mode_gid - Off
safe_mode_include_dir - <i>no value</i>
sql.safe_mode - Off
upload_max_filesize - 64M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
safe_mode_allowed_env_vars - PHP_
safe_mode_protected_env_vars - LD_LIBRARY_PATH
Remo replied on at Permalink Reply
Remo
you've already overridden mail/block_form_submission.php. Does the form work now? Does it work if you remove that file? Everything else looks good..
splashby replied on at Permalink Reply
splashby
I'm good now, thanks. I checked the override (which was a simple replacement of text) and the override block was... empty!...which may have been more of the factor in this case...

Thanks again. Appreciate the quick response.
iumeo replied on at Permalink Reply
Hi Remo,

I added more information about my case.
I updated one site from 5.5.2.1 to 5.6.3.1.
As I saw, we need to be more pragmatic when we update a site because some variables can change.