Error after Canonical URLs

Permalink 1 user found helpful
In Concrete5 5.7.5.1
I just enable the Pretty URL's in settings. And I put the canonical URL and "save"

Now my pages, dashboard etc. show only this:
"The given URL: `http:/www.sekaman.fi` could not be parsed"

I have empty the htaccess. but it didn't work...

In the dashboard>setting...>SEO...>URL... is this line in the bottom:
"Ensure that your site is viewable at the URL(s) above before you check the checkbox below. If not, doing so may render your site unviewable until you can manually undo this change."

How do I undo this manually?

SEKAMAN
View Replies:
NEONOON replied on at Permalink Reply
NEONOON
I'd the same issue and could not find a way to reverse it quickly.
The option is great, but really needs further information and help.
Actually i ended up wiping the whole template and started over
again. I'm a C5 starter, but until this option is explained more in
detail (manual reverse) i will avoid using it. (sorry, not much help
here. but i'm sitting in the boat /same questions :-)

Regards, Chris
SEKAMAN replied on at Permalink Reply
SEKAMAN
Thanks for the reply.

I think that starting all over again is my only option.
I did build a new site with C5 (V5.7) and was just about to launch it...
Just forgot to take backup at "so early stage"

Have been use the Concrete about 3years now.
And before upgrading to the V5.7, I really consider other platforms as well, like Drupal, Joomla etc. But I like the Concrete platform, and all the simplicity of it.
Even if it is not so customizable... But it get the job done.
And it is capable to create easily a professional looking pages.

But I wish that there would be more basic addons for less money or even free ones.
And more active community...
Maybe in the future... or not... who knows
OKDnet replied on at Permalink Reply
OKDnet
I just had this happen the other day when I accidentally entered http://http://mydomain.com in the Canonical URL field
After that of course things broke. At first I tried emptying the .htaccess file, but that didn't work.
The fix was to use web inspector to see the incorrect urls, and manually enter the correct urls to get back to the page where we screwed things up, and re-enter the correct info. Part of the trick is that the url from the form will be incorrect too, so you have to inspect and correct that url too (again manually entering it to submit the correct info to fix everything).

I'm planning on doing a "How To" to help anyone else who runs into this, because I assumed if I accidentally did this, others probably will too. Well that has obviously been confirmed
SEKAMAN replied on at Permalink Reply
SEKAMAN
I think that there are many people, who have or had made this "error"
I'm not sure was my error caused by the wrong URL (www. or without it)
So a proper "How To" fix it, is indeed a good idea.

I just "fix" this in the hard way... deleted the Concrete installation and start from the new installation of it.
NEONOON replied on at Permalink Reply
NEONOON
Hi, yes this option needs proper information support.
It's said that Concrete5 is good for design, easy info
would further underline that.

@SEKAMAN
I came to Concrete5 for responsive technique, some
templates (design/responsive) and support. It seems
quite a good system for sites not so much for shops.
E-Commerce add-ons for euro banking are missing
or haven't been upgraded yet. The version break ca.
1,5 years ago is a good thing, the latest 5.7 updates
which include mobile previews are nice.

The process of purchasing templates/add-ons in the
market, the communication/system reply after that
and support by developers make me stay a while :-)
SEKAMAN replied on at Permalink Reply
SEKAMAN
I use a Opencart for e-commerce.
And Concrete5 just a information website. :)
NEONOON replied on at Permalink Reply
NEONOON
@OKDnet
Do you mean something like the "Safari Web Inspector" ? (here's the URL ..developer site)
https://developer.apple.com/library/safari/documentation/AppleApplic...

When getting errors using the Canonical URL option, i actually tried to simply reverse
that very funtion via the Concrete GUI. Since i could'nt log-in any more to change the
settings, i "simply" wiped everything and started over. How could one log-in without
using the GUI ..to change settings (in this case, deactivating cononical URLs) ?

Regards, Chris
OKDnet replied on at Permalink Reply
OKDnet
Well I used the Chrome browsers inspector, but yes.

The reason you can't login is the form is sendng the wrong URL. And yoy may already still be logged in, in which case you just need to know the actual url of where you want to go, such as

http://yourdomain.com/index.php/dashboard/system/seo/urls...
or if your not still logged in, go to
http://yourdomain.com/index.php/login...

@ SEKAMAN I'll put it all in a video tutorial soon.
guymon replied on at Permalink Reply
ftp in and go to
application/config/generated_overrides/concrete.php

the Canonical Name is saved there in the seo array.

Permission was set to nobody so I ended up just SSH in and changing it with VIM.
wawahue replied on at Permalink Reply
wawahue
So... I'm a programming novice but .... I am able to get into the file and change it through my cpanel - my question is....what do I change it to?😯
asaucier replied on at Permalink Reply
asaucier
Saved my day! Thank you!!