Error: Invalid Form Token

Permalink 1 user found helpful
I'm working with version and have a problem that is occurring when trying to either delete or rename ANY block within a Scrapbook. I can add a new block, I can edit the contents of a block, but I can't delete or rename them without getting this error:

The following errors occurred when attempting to process your request:
Invalid form token. Please reload this form and submit again.

I'm reluctant to upgrade to v5.5 (which uses Stacks instead of Scrapbooks) as a large part of the site uses custom methods of displaying the content of the scrapbooks.

Has anyone come across this error before and got any ideas of how to fix it? I have already upgraded from v5.4.1.1 (the error occurred before), tried clearing the cache and tried logging in as a different user, but I'm still getting the error.

Any suggestions?

View Replies:
juliandale replied on at Permalink Reply
I managed to fix the problem. I'm still not sure how it occurred, but basically I had to reset the installation to get it to work.

For your reference, what I did to fix it was:

- Delete the file located at /config/site.php
- Go into the CPanel and then phpMyAdmin (the database manager)
- Export all of the tables to back them up and then drop them all to leave an empty database
- Visit the website and run through the Concrete wizard to configure a new database installation
- Go back into the phpMyAdmin and drop all of the tables Concrete just set up
- Restore the database tables by pasting in the SQL generated from the database export
- Log in to the website and activate the site's theme

I had tried deleting all of the files and re-uploading them and also reinstalling the database from my local copy, but that didn't work, so I wonder if there was an issue with file permissions or the config file that had caused the problems.
balods replied on at Permalink Reply
Thanks for the post Dude! ^^
prema520 replied on at Permalink Reply
Hi all!
Just in case you're still looking for this, in our case a upgrade was breaking a profile form override that we had created.

What fixed it was
$attribs = UserAttributeKey::getEditableInProfileList();

just under the form tag. Please post back or pm us if you want more detail.
Aquizile replied on at Permalink Reply
Nice one:: Thank you.

It solved it for me... Just edit the edit.php file in: concrete/single_pages/profile/edit.php
simonchilton replied on at Permalink Reply
Brilliant, worked like a charm! Thanks!!