Error (Upload Error: 404) when try to upload big size (240Kb) file

Permalink
Hello everyone,

I user concrete5.6.1.2_updater version.I am trying to upload 240kb file from file manager but it gives me error UPLOAD ERROR:404, whereas small file upload is working fine. So i tried to change the parameters of php.ini as below

max_execution_time - 360
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 128M
post_max_size - 8M
sql.safe_mode - Off
upload_max_filesize - 2M
memcache.max_failover_attempts - 20
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
xcache.var_maxttl - 0

As i have applied all the parameters that should be affecting upload but still it dont works. So can anyone please say me why it is so? Is there something that i am missing ? Please help to get me out of this.

View Replies: View Best Answer
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
try to upload any other big sized file. Maybe that particular file is corrupted.

Rony
savan replied on at Permalink Reply
Hello Rony,

Thanks for your reply but i have changed 2 or 3 pdf files with about 240kb size but still it dont works. Also the same file works in local when i try to upload. So any other suggestion?
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
Try to upload any big sized image. Also check your Allowed File types from dashboard.
savan replied on at Permalink Reply
I have tried to upload image of 240kb and same issue , it gives upload error. Also pdf is in list of allowed size as i can upload small size of pdfs.
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
Strange! Check your hosting disk space to be sure that its not full.

Rony
savan replied on at Permalink Reply
But when we try to upload from ftp the same file it is working fine with no issue.
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
As you have told that it is working fine in your local, there are few possibilities.

1. Maybe some files or folders were not uploaded properly while transferring from local to server.

2. Does your site root have a folder called "files" and is it writable?

3. Does your single file upload works perfectly?

4. Have you checked this with any other browser?

Rony
savan replied on at Permalink Reply
My single file for small size upload is working fine i.e. i tried to upload 60kb file and that upload working fine. but when i try to upload 240kb size(of single file) then it gives upload error. Also yes i tried with 3 brwosers ie,ff and chrome all have same issue
JohntheFish replied on at Permalink Reply
JohntheFish
There are a couple of limiting factors on file uploads outside of concrete5.

PHP places a limit in the php.ini file

The apache web server places a limit in the apache configuration file.

Your web host service should be able to tell you both limits and advise whether any adjustments can or should be made.

You can also install phpinfo.php as a root file (dangerous, possible security leak if you leave it there), or using the phpinfo addon (free) to show the info from the dashboard.
http://www.concrete5.org/marketplace/addons/php-info/...
savan replied on at Permalink Reply
Hello

Thanks for your reply , ye i have phpinfo.php on my root and i have this values from there only

max_execution_time - 360
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 128M
post_max_size - 8M
sql.safe_mode - Off
upload_max_filesize - 2M
memcache.max_failover_attempts - 20
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
xcache.var_maxttl - 0

Does i miss anything?
JohntheFish replied on at Permalink Best Answer Reply
JohntheFish
I looks like the php settings are fine. You need to contact your host about any apache server limits.

For example, some shared host accounts may have an apache upload limit way smaller than the php limit, so the upload never gets as far as php.