Exclude Subpages from Nav

Permalink
I've been working with 5.7 after spending a lot of time with 5.6. One thing that seems to be missing is the 'exclude_subpages_from_nav' page attribute.

I've put it into my site using the attribute settings interface but it doesn't seem to be doing anything. Was this attribute removed between 6 and 7?

View Replies:
MarcYBB replied on at Permalink Reply
MarcYBB
MrWalshMan,

The exclude sub pages from nav should be on the left hand side under the heading of navigation and indexing of the attributes screen that is accessible when the gear icon is clicked, or from the pop menu accessible when a page is clicked from the site tree.

Click on the attibute so it becomes highlighted, at which point is appears in the body of the attributes. Check the box to activate that attribute.
kspitzley replied on at Permalink Reply
kspitzley
As far as I can see, at least on 5.7.4.2, that attribute doesn't come pre-installed. I added it manually and it worked, but I just wanted to note that.
tabercreative replied on at Permalink Reply
tabercreative
The attribute handle "exclude_subpages_from_nav" is not working for me in 5.7.5.1. Anyone else having the same trouble, or a workaround?
kspitzley replied on at Permalink Reply
kspitzley
It's working for me in 5.7.5.1...maybe you have a typo or the wrong kind of attribute?
tabercreative replied on at Permalink Reply
tabercreative
It suddenly started working after I abandoned it all together. I'm guessing it has something to do with later running an automated job like Index Search Engine. Not sure.