Fatal error: Class not found in /concrete/core/libraries/loader.php (since updating to 5.6)

Since I updated a website from 5.5.2 to 5.6 the Date Navigation block is caussing trouble:

The page where the Date Nave Navigation block is used, I get a total white pagina, with only this error:

Fatal error: Class 'DateNavBlockController' not found in /var/www/domains/parousiawijchen.nl/www/concrete/core/libraries/loader.php on line 402

On other pages, when I try to add a new block, I get the same error.

When I try to edit the addon (I wanted to try to delete it), same error.

I have no idea what to do now? Is the Datenav no longer available in 5.6? How can I either fix or remove it?

3 Attachments

View Replies:
AgLab replied on at Permalink Reply 1 Attachment
I just had this exact thing happen to me on a block I created. I was able to go into phpMyAdmin and remove the block type directly from the database. A little scary if you don't know what you're doing but it worked for me. Let me know if you need a step-by-step.

mhawke replied on at Permalink Reply
5.6 has an additional cache called the 'Overrides' cache. Try turning it off by visiting 'Dashboard->System and Settings->Cache and Speed Settings'. While you're there, turn off all the caching and clear the cache.

If that fails to fix it, have a look to see if you have any 'override' files in [root]/blocks/date_nav. If you do, try temporarily re-naming the [root]/blocks/date_nav folder and see if that clears things up. Overriding in 5.6 is 'stricter' about things and I ran into this problem on a couple of my customizations.

Oh and I think there's an ointment you can buy to treat 'white pagina'.
enochf replied on at Permalink Reply
@mhawke, I'm having the same issue. I Tried the caching items, but it didn't do anything. I also tried renaming the directory and then refreshing the page and then changing it back, but that didn't work.

My problem happened when I tried to run the site on localhost. I can navigate to any page that doesn't contain the problem block, but any page with it gives me the following error:
Fatal error: Class 'TwocolBlockController' not found in C:\xampp\htdocs\mysite\concrete\core\libraries\loader.php on line 420

I installed the site on the actual server in the same manner with the same database and it works just fine. Any help would be much appreciated.
mhawke replied on at Permalink Reply
When you say that you "tried renaming the directory", which directory are you referring to?
enochf replied on at Permalink Reply
Thanks for getting back to me so quickly!

I tired temporarily re-naming the [root]/blocks/twocol directory which contains the particular block that's giving me the trouble.