File Permissions for images

Permalink
I've installed c5 onto a linux server hosted with 123-reg. All fine until I upload images with File Manager, no thumnail or image although info all there. Found post about it and changed file permissions to 777 for /file and recurse into all subdirectories which worked. But then when I uploaded another image - same problem - checked file permission for that image and it was 664.

So how do I make sure that images uploaded have the 777 permission?

I don't have any php knowledge but can access phpmyadmin through 123-Reg website.

greyhare
View Replies:
Steevb replied on at Permalink Reply
Steevb
Hi,
I've never had this problem?

I do file manger, lets say - multiple uploads, navigate to want I want and choose. Then upload and works just fine?

A little while ago there was an issue with 'Flash', which the interface uses, is that OK?

But I have never had to check permissions?

I also use linux server and it is a shared server.

There must be something else happening?

Is there an issue 123 hosting?

Do the paths match?

Food for thought?
greyhare replied on at Permalink Reply
greyhare
Yes it is a bit odd, I'm having to upload a few images at a time and then change the file permission to 777 to whole of /files and then when I refresh all the thumbnails and images appear. So I think it has to do with permissions or it is a weird coincidence that happened 5 times in a row! I think I'll take your advice and try asking 123-reg next.

Thanks for reply.
greyhare replied on at Permalink Reply
greyhare
This is response from 123_reg:

"I'm afraid that by default all new files are created on our shared hosting server with permissions 664. This is a global setting and cannot be altered as it will affect all other users. You will need to manually change the permissions after uploading the pictures. Please note that permission 775 is enough for applying it to the pictures.

So it looks like I'm going to have to go through this process everytime I upload images if I'm with 123-reg! Luckily it's a small site and I only used 123-reg as my client was already with them - I will avoid in future.

Does anyone know a way of getting around this, has anyone encountered this before?
webfusion replied on at Permalink Reply
Hi

I work on behalf of 123-reg.

I would be interested in following up on this for you.

Can you provide me with either the support ticket reference or the domain name please.


Regards,

Ricky
greyhare replied on at Permalink Reply
greyhare
Hi Ricky

My TICKET ID: 111009-000053
Laurentiu
Site: esteponarental.co.uk

This is a small simple site, so changing file permissions after uploading images isn't too troublesome, but I am planning to build a much more complex C5 site for the same client who has many domain names with 123-Reg, and would like to host with them as well.

So, I would be grateful of any help you could offer, the site is also running very slowly on 123-reg, I originally developed it on 1&1 and it was alot faster, any ideas why?

BTW - could you reply to me rather than Martine (the account holder), I used her login which is why support is using her name.

Thanks very much for your reply,

Sarah
webfusion replied on at Permalink Reply
Hi

I have arranged for our system admins team to investigate your issue for you, a reply is now on that support ticket if you can login and view it.

If possible can we correspond directly on the support ticket.


Regards,

Ricky
CreativeLabel replied on at Permalink Reply
Hi Ricky,

I'm having the same problem. Did you find a resolution?
CreativeLabel replied on at Permalink Reply
Has anyone had a resolution this problem, I have exactly the same issue?
webfusion replied on at Permalink Reply
Hi

You can try the below advice which may resolve your issue.

Advanced permissions
http://www.concrete5.org/documentation/installation/installing_conc...



Ricky
edwardg8 replied on at Permalink Reply
Hi,

This appears to be related to the following bug:

http://www.concrete5.org/developers/bugs/5-4-2-1/chmoddir-mode-vs-m...

I've fixed this on a site hosted on webfusion shared hosting with the following...

modify:
concrete/helpers/concrete/file.php

After each use of @mkdir, add:
@chmod([replace with directory arg from mkdir],0755);

The problem is that the umask setting on webfusion's php setup strips the execute permission from the directories created by php, so you have to correct the permissions after the directory has been created.

Hope that helps,
Gareth