File upload help!

Permalink
Hi,

I'm having a bit of a problem with uploading files. When uploading any images or set of images above a certain resolution I'm getting file upload error 314.
I've changed the php.ini file and set the max file size to 8mb and the post max file size is set to 128mb - much higher than the photo(s) I am trying to upload which are around 4-5mb. The file size does not seem to be the issue though - the only thing that seems to fix the issue is resizing them to around 1000px. Could somebody shed any light on what's going on? Is there a maximum dimension limit setting I am missing somewhere?

Many thanks in advance!

View Replies:
madeforspace replied on at Permalink Reply
madeforspace
Can you tell us what is giving you the 314 error? Is it a C5 message or FTP client? Could you post a screen of it happening?
labber replied on at Permalink Reply 1 Attachment
It's a c5 error appearing in the add files upload box. It's actually a 413 error, my mistake. I've attached a screenshot
madeforspace replied on at Permalink Reply
madeforspace
My initial answer would have been the file location was not set correctly but this does not account for files under a certain size being uploaded ok so I guess that ones out.

I know you said you changed the php.ini file to allow larger file sizes but have you checked that the server is actually doing what you asked? Have you put up an info.php file and got confirmation back from the server of the limits that are set. You may need an apache restart after you make a change to the php.ini on some servers anyway.

Also what file type are you uploading? Are they accepted in the file type list, again a weak one due to the size issue but worth a check.

Check the file permissions too but again this pesky file size issue means the either all should work or not work.

Have you tried using the incoming folder for large file types? That is my best guess at a solution, upload the large files to the incoming folder the add them to the file manager that way.
Post back if you want to know in more detail how to do this one.
labber replied on at Permalink Reply
Thanks very much for your help however none of your suggestions seem to be the solution to my problem :(

Yes I am certain the php.ini limits have been set. I've checked in the environment settings in Concrete5 & the screenshot I attached shows the set limits above the Upload file box too.

File type is definitely accepted (jpeg) as it is allowing me to upload jpegs with smaller dimensions (around 1000px width) but not much larger (regardless of file size).

I have not tried the incoming folder, thanks for that suggestion, however this doesn't help as far as the client is concerned if they want to upload a large file in future as they won't have access to that folder.
madeforspace replied on at Permalink Reply
madeforspace
Just as an after thought do you have a error log produced in your public_html folder, that may hold some more clues.

You may have seen this already but it is an interesting thread about a similar problem.
http://www.concrete5.org/community/forums/installation/solved-uploa...

I can't think of anything in C5 that is blocking the upload, my guess is that it is a server/php issue but it is really impossible to say for sure.
labber replied on at Permalink Reply
Thanks for the reply.

I created a demo concrete5 site using concrete5.org. The demo site accepted my file. I gather it has to be a PHP/Server issue.

But, my php.ini file has been changed. The is the current setting:

Upload Max: 128M. Post Max: 16M

It is reflected in the Environment Info and on when you open the window to upload multiple images.

So I want to say I can rule out a PHP error. So what could I change on the server to prevent this from happening?
mnakalay replied on at Permalink Reply
mnakalay
Hello,
I have posted an answer for you on Stack Overflow but here it is again just in case:

Both Apache and php might be limiting how much data you can upload through an http request (different from ftp)

You already made changes to your PHP.ini but I have to point out that it is not max_post_size but post_max_size that should be used.

On the other hand, Apache has a LimitRequestBody directive (http://httpd.apache.org/docs/2.0/mod/core.html#limitrequestbody) That directive allows to set a limit to the size of http requests.

Of course if you are on a shared server you might have problems controlling that but it's worth asking your host about it.
labber replied on at Permalink Reply
Hi. Thanks so much for your reply. I am sorry, I have changed the post_max_size. I typed the wrong thing there. I will take a look into this.
edsaxmoore replied on at Permalink Reply
edsaxmoore
Did you ever figure this out? I am having the same issue and have tried everything (almost). Clearly I am missing something.