form block- not sending email

Permalink 1 user found helpful
I have a strange situation with sending email from a site.
my host will only allow a qualified email address setup in cpanel.
if i setup in SMTP and run back end email test the email arrives.
If i then use a form and test the email shows as sent and is recorded in the CMS but it never arrives as the destination email set in the form preferences?

Ive tried countless time editing the code in config/concrete.php and every other option.
My hair is now very grey.

deanhawthornthwaite
View Replies: View Best Answer
deanhawthornthwaite replied on at Permalink Best Answer Reply
deanhawthornthwaite
i've solved this myself after days of research.
Would have been nice to have some response from the community but i've noticed of late this seems to have dwindled quite drastically.

For anyone who is having email delivery problems using standard FORM BLOCK, please read on....
Version 8.4.5 system settings now has 'System Email Addresses' options.
yoursite.com/index.php/dashboard/system/mail/addresses

If your hosting provider will only allow sending out email from a qualified address on their server, you have to enter that address in the 'default email address' and the 'form block email address' sections of the above settings and then save.

This writes to a file in: application/config/generated_overrides/concrete.php
I stupidly edited this file directly in a desperate attempt to get my email working but then couldn't change it in the back end settings, so please don't make same mistake.

Ive also found that i can use the 'Default PHP Mail Function' or setup the custom 'External SMTP Server' with hosts qualified email address settings. On my host either seems to work.

I had the problem that i could send a test message but the form block would not send out email even though there were no error messages and it looked like it was sent.

hope this helps someone. :-)