Form block not sending form submissions by email

Permalink
Hi all,
In my C5.5.2 setup the Form block does not send emails to me when someone submitted the form. I can see the messages in dashboard/reports/form results, but do not receive an email. I've tried different emailaddresses, to be sure the email is not blocked by a spamfilter.
Can it be a server-thingy?

zeker
View Replies: View Best Answer
anchoredbutterfly replied on at Permalink Reply
anchoredbutterfly
Did you tick the box to enable email notifications in the form settings?
zeker replied on at Permalink Reply
zeker
I did.

Op 15 mei 2012, om 15:59 heeft concrete5 Community het volgende
geschreven:
adajad replied on at Permalink Reply
adajad
What does your logs say? ( dashboard/reports/logs )

Do you receive other emails from your c5 installation?

What SMTP settings do you have? ( /dashboard/system/mail/method/ )
zeker replied on at Permalink Reply
zeker
adajad replied on at Permalink Reply 1 Attachment
adajad
Instead of using the default PHP Mail function, try to use gmail for SMTP with the settings you see in the attached image(assuming you have a gmail account).

By doing this we can determine if the problem is with your PHP mail().
zeker replied on at Permalink Reply
zeker
Hi Adajad, that is working. I'm receiving email from our gmail-account.
So there is something wrong with out PHP mail().

Do you have a suggestion on how we can fix that?

(I'm allready very happy with it working for now!)



Op 16 mei 2012, om 09:38 heeft concrete5 Community het volgende
geschreven:
adajad replied on at Permalink Best Answer Reply
adajad
I would contact the host regarding this as they might have blocked the mail function (which seems stupid).
zeker replied on at Permalink Reply
zeker
Thanx for your help Adajad. I will do that.


Op 16 mei 2012, om 10:25 heeft concrete5 Community het volgende
geschreven:
ProjbyP replied on at Permalink Reply
ProjbyP
Kudos for your response and screen shot - I have been having all kinds of troubles with email forms and this saved my butt! and kept both me and my customer happy! So thankful for your help.

If you have come to Mifflinburg, PA, stop by Projects by Peggy, Inc. and I'll get you some Amish goodies!

Oh I could dance a jig today!!! ;-)
timmeh00 replied on at Permalink Reply
I am also experiencing this problem.
I have tried both the default PHP mail and SMTP methods. I have tried using several email addresses and 2 different SMTP servers including Gmal.
Yes i have ticked the "notify by email" option and the form results appear in Reports>Form results and Reports>Logs.

Is there a better way to test or debug the Form Block functionality?
I am running version 5.6.1.2.

EDIT:

Okay so i've got it working all sweet, but first a couple things i did before the final step may or may not be attributed to its success.

First i tried adding these lines into /config/site.php
define('EMAIL_DEFAULT_FROM_ADDRESS', [email protected]');
define('EMAIL_DEFAULT_FROM_NAME', 'Company Name');

What adding this to your site.php does is sets the default email address Concrete5 uses to send notification emails, forgotten password requests etc.

Now what i had also done at this point was setup an email account, same as i had used in my site.php.
Then in Dashboard>System & Settings>SMTP Method i am using external SMTP, i am authenticating using details of the account i set up earlier and in my site.php.

Still not working, but next is what i did to get it working.
In my hosting control panel through your hosting provider e.g. mine is cPanel, i went to MX Entry and set it to Automatic from Local Mail Exchanger.
When i set it to Remote Mail Exchanger which is what i tried first, i got all my emails Concrete had sent to me in my desktop mail client but could not send and receive with other email accounts on the same domain/host.
When i had it set on Local Mail Exchanger, i could send and receive emails like you would normally, however, nothing would come through from Concrete5.
So third time lucky, i tried Automatic and it worked.
negs replied on at Permalink Reply
Thanks! This worked for me.
waltbx replied on at Permalink Reply
Setting the Local Mail Exchanger to "Automatic" worked for me, too. For months I could not resolve this problem. Thanks!

"When i set it to Remote Mail Exchanger which is what i tried first, i got all my emails Concrete had sent to me in my desktop mail client but could not send and receive with other email accounts on the same domain/host.
When i had it set on Local Mail Exchanger, i could send and receive emails like you would normally, however, nothing would come through from Concrete5.
So third time lucky, i tried Automatic and it worked. "