Getting this error after upgrading from 5.7 to latest version

Permalink
Hello All
I'm getting the below error while upgrading one of my site from 5.7 to latest version. Any idea how to fix that?

TypeError
Argument 1 passed to Concrete\Core\Attribute\Controller::__construct() must be an instance of Doctrine\ORM\EntityManager, instance of DoctrineProxies\__CG__\Concrete\Core\Entity\Attribute\Type given, called in /home/cdldev/siteurl.com/packages/problog/blocks/problog_list/templates/categories/view.php on line 18


Thanks in advance
Rony

ronyDdeveloper
View Replies:
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
Any help! Please
JohntheFish replied on at Permalink Reply
JohntheFish
Problog is not compatible with v8 and is no longer supported. You will need to either
a) Fix problog for v8 compatibility.
or
b) Install problog before updating and make sure any debris from its installation is removed.
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
Hi John
I was fixing the problog issues one by one but got stuck with this one. Cannot understand how to fix this.
JohntheFish replied on at Permalink Reply
JohntheFish
There were big changes to the way attributes work between 5.7 and v8. Problog is heavy on attributes. Attributes use entities.

Some general tricks, may help.
In the dashboard entities page, make sure doctrine/database is in development mode.