Google Maps Are a Nightmare to Work With

Permalink 1 user found helpful
I am having the worst time trying to add Google Maps to any given page.

I'm using 5.7.5.9, and have set up an API. However, when I try to enter the location, nothing appears in the dropdown, and when or IF it does appear and I select it, I am given an error and can't add the block. Keeps telling me I haven't selected a valid location, even though it is correct.

This API upgrade thing is a huge nightmare.

Anyone else having trouble adding Google maps?

PineCreativeLabs
View Replies: View Best Answer
Advite replied on at Permalink Reply
Advite
The changes have definitely caused quite a few headaches and quick learning curves in the past month or so.

Different map implementations require different API libraries to to be assigned to a key in order for them to work correctly.

So, It may be possible that you need to add a certain library to your key to enable your map to load properly.

If you view the source of the page your map is on you should be able to see the Google maps url and at the end of that url should be the libraries that are required.

for example: this map requires the 'Places' library

<script src="https://maps.googleapis.com/maps/api/js?key=Th1zI5N0taNAp1Kee&libraries=places"></script>


If you log into your Google API dashboard you should be able to add libraries to your key from there.

If you still have trouble getting the maps block to work then you might want to take a look at my free Styled maps add-on on the marketplace.

https://www.concrete5.org/marketplace/addons/styled-maps...

also, see below for obtaining the correct API for Styled Maps.

https://www.concrete5.org/marketplace/addons/styled-maps/how-to-get-...

Hopefully one of these options will help you or someone else out.
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
I tried using your Styled Maps addon, as well as others, including the core block, but had the same results. At first, I thought it was a bug, but it really seems to be on Google's end.
Advite replied on at Permalink Reply
Advite
This is probably a silly question, but have you tried generating a brand new API key?

Just remember if you do generate a new key, make sure that it is referencing the correct library.

If you are unsure, follow the link in my previous reply above on obtaining an API key and try it with the Styled Maps add-on as I know that link will send you to the correct location to gain an API key with the correct library associated for that particular add-on.

If that still doesn't work then it may be something like a javascript conflict causing an issue?

But I would try generating a new key first and see how that goes.
banditetr replied on at Permalink Best Answer Reply
banditetr
Hi just had same problem. I fixed it with aktivating the Google Maps Web Service API together with Google Maps Java API and Geolocation API

I hope it helps you

banditetr
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
That worked perfectly! Thank you!
pnunn replied on at Permalink Reply
Thanks. Turning on these extra API's seems to have sorted it for me too on the latest build.. That took some finding. :)