Google Maps Display Problem

Permalink 1 user found helpful

I am using the latest Concrete5 version and I am a huge fan! Nevertheless, I am building a block based on the Google Maps Enhanced add-on. My problem is the display of the Google window and the navigation. I am using Google's latest maps api. Maybe someone had the same experiences in the past and can tell me how to fix it? Thank you,


P.S.: An image is attached.

1 Attachment

View Replies:
arrestingdevelopment replied on at Permalink Reply

If no one here is able to help you, you might want to try submitting a support request to the developer of the Add-On. You can do that by visiting the Add-On's page in the marketplace (here: ) and then clicking on the "Support" option in the right-hand list of options.

- John
MichelHerszak replied on at Permalink Reply
Thanks John. I am going to do this.
njerabek replied on at Permalink Reply 1 Attachment
i have the same problem ( see screenshot ) even with the "concrete-default" google-block" and other add ons that use maps.

found some info at stackoverflow ( )

>>All of the problems, as far as I can tell, are a direct result of putting the map into a jQuery UI tab. Though people in the maps group might have experience with this, it didn't seem like the place for this question. I might end up asking around.<<

would you please be that kind and let me know if you've solved this issue ?

JohntheFish replied on at Permalink Reply
The explanation and fix is in

This fix is now built in to the 5.6.1 maps block. Solutions available (in my order of preference, but you may have other priorities):

1. Upgrade to 5.6.1

2. Use the Formigo directions block

3. Load your map using Blocks by AJAX

4. Copy the revised block from Github and use it to override the block in your site.

5. Hack the code in the howto into your block.
njerabek replied on at Permalink Reply
thanks john for your prompt reply and the work around ways you listed hierarchically ( what a service !! )
BUT … i'm still stuck with this messed up google-map-nav-thing...

i did upgrade concrete to to 5.6.1, just acquired and tested your " Blocks by AJAX " still not the desired effect. At last i tried to implement the code from your link, but don't exactly know where to put it … but you stated that these lines would be included in the latest version of concrete anyway ?!

here would be an example of a map ( concrete v5.6.1 ) with your ajax-block-template applied … but, sadly, still messed up, … would be great if you could have a look, … i'm going nuts here …

regards nj
njerabek replied on at Permalink Reply
just figured it out;

using a bootstrap based theme, this issue seems to be related to the framework.

but its not only bootstrap but some relevant blocks too.
there are two ways to solve this /

first : maps render fine as long as the selector is named : "map_canvas" ; some addons will give you ids like "map_canvasX" - rectify this and ( in my case, maps will render fine )

second : ... and this refers to bootstrap ( mainly ) … css has to contain: map_canvas img with the attribute : max-width : none;
it was fairly easy to get this done, … after hours of frustration …
OKDnet replied on at Permalink Reply
I'm running the latest version of C5 v. 5.6.2 and I had this happen as well. This did fix it though.
I had to add

.googlMapCanvas IMG
{ max-width: none;
#googleMapCanvas131 IMG
{ max-width: none;