https redirecting to https://localhost after SSL installation

Permalink
Hi everyone,

I'm not sure if I posted this in the wrong forum previously, however I've received no response so I wanted to try one more time.

I recently installed an SSL certificate on my website and when I try https:// mydomain.com it redirects to https:// localhost:8888.

If anyone has any advice on what I should do next, I would truly appreciate the guidance.

Of note is when I go to http:// mydomain.com it does work properly. It's just with the https:// that seems to be the issue right now. I've never set up SSL before so I'm not sure what to do next.

Thank you,
-concreteart

View Replies: View Best Answer
johnpaulb replied on at Permalink Reply
johnpaulb
Hello concreteart,

I recomend checking that your SSL is installed and configured correctly for your specific domain/account, as this error looks like it is attempting to us the default server SSL.

Here is a link to a helpful 3rd party website that can scan and check your SSL:
http://www.sslshopper.com/ssl-checker.html...

Hope this helps,
-John-Paul
concreteart replied on at Permalink Reply
John-Paul,

Thank you so much for replying! I was starting to think no one would respond :)

I went ahead and tested my SSL certificate through the link you provided.

It resolved at the right IP, listed the correct software (LiteSpeed), "certificate should be trusted by all major web browsers (all the correct intermediate certificates are installed)", certificate was issued by Go Daddy, lists the days it is valid for, hostname is correctly listed in the certificate. And then the Server, Chain, Chain listed below are checked and show as correct.

With this information, do you still feel I should contact my webshost to see that it is not trying to use the default server SSL?

They are actually recommending that I create a blank index.html and rename the index.php and try that...I'm not sure if I should do that or not.

Also of note, I currently have the site in maintenance mode through the Maintenance Editor add-on (not sure if that could affect this).

Thank you so much for your assistance with this. This is a relief.
johnpaulb replied on at Permalink Reply
johnpaulb
Hello concreteart,

If possible, I would disable any addons just to rule them out.

Since it looks like your request is being rewritten to the localhost:8888, I would check the .htaccess to make sure there is nothing there (redirection, etc.)regarding port 8888.

If not, then check the apache configuration, or have your host check it, because this is not a typical error.

I hope this helps,
-John-Paul
concreteart replied on at Permalink Reply
Hi John-Paul,

Thank for the response! I disabled the Maintenance Editor and tried https:// and it still redirects to localhost:8888. I did look at the .htaccess file. Here is what is in it:

# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
# -- concrete5 urls end --

Does this mean anything to you? Is there anything here that might be causing this problem?

The only other add-ons I have are:

eCommerce
Slate Theme
Social Icons Reloaded
AddThis
Maintenance Editor

Is there a way to disable these add-ons without uninstalling them?

Also, my server is running LiteSpeed. Does that present any problems v. running Apache?

Thank you!
-concreteart
mkly replied on at Permalink Reply
mkly
Did someone mention Maintenance Editor? ;)

One thing I'm noticing about this is that it's redirecting to port 8888. That's a bit odd. Do you have anything in your config/site.php file that might be referencing this?

Best Wishes,
Mike
johnpaulb replied on at Permalink Reply
johnpaulb
Hello concreteart,

Your .htaccess file looks pretty standard. I would check what mkly is mentioning (the config/site.php).

Otherwise, it looks like when the SSL was installed on the server, something was not setup correctly. I would suspect the Virtual Host entry in the apache configuration (httpd.conf) is incorrect.

I hope this helps,

-John-Paul
concreteart replied on at Permalink Reply
Hi mkly and John-Paul,

Thank you so much for the assistance on this.

I took a look at the config/site.php file and this is what it shows (edited passwords in [ ], etc):

<?php
define('DB_SERVER', 'localhost');
define('DB_USERNAME', '[displays the username]');
define('DB_PASSWORD', '[displays password]');
define('DB_DATABASE', '[displays database name]');
define('PASSWORD_SALT', '[a long list of letters, etc]');?><?php define('DIRNAME_APP_UPDATED', 'concrete5.6.1.2_updater');?>

--
Should the DB_SERVER be something other than 'localhost'??

Thanks,
-concreteart
concreteart replied on at Permalink Reply
Anyone?
mkly replied on at Permalink Reply
mkly
Hi concreteart,
I strong suspect that your Apache configuration(if you are using that) is misconfigured. Likely something like you've set the SSL port to 8888. Is this a server you manage, or a you using a shared hosting provider?

If it is your server, remember you can only have one SSL per IP afaik(my Apache is so so). That's where I would look at this point.

Best Wishes,
Mike
concreteart replied on at Permalink Reply
Hi mkly, thank you for the response! This is a shared server and I have a dedicated IP.
concreteart replied on at Permalink Reply
Well,

After asking my web host to check the virtual host issue, they said that everything was correct on their end and to have the "developer" (developer of Concrete5) "check the script" as they feel it is a "script issue".

Any idea what this means? I feel like I am at a dead end and I don't know what else to do??
johnpaulb replied on at Permalink Reply
johnpaulb
Hello concreteart,

Is there anything in your error_log? It is located in the root of your Concrete5 installation.

I would enable logging, here is a link to an article I did:
http://www.webhostinghub.com/support/edu/concrete5/groups-permissio...

Also, make your errors display. Here is a link to an article on that:
http://www.webhostinghub.com/support/edu/concrete5/groups-permissio...

Let us know of any errors you can find.
-John-Paul
concreteart replied on at Permalink Reply
Hi John-Paul, thank you for the reply. I checked my error log and have this in it:

[21-Mar-2013 00:45:41 UTC] PHP Fatal error: Call to a member function submit() on a non-object in .../public_html/concrete/single_pages/dashboard/system/backup_restore/backup.php on line 66

Also, I checked the error logging and display errors and they were both already checked and turned on.

Could this localhost redirect have something to do with the fact that I started out on my localhost at first? But then it seems odd that http: works but https: is getting redirect to it.

I did notice in my customize theme area to add to your .css for the banner image that I had a link still trying to pull from localhost:8888/...and so forth for the image. Obviously I will be updating that link, but seems unrelated to this issue.
concreteart replied on at Permalink Reply
Is there anyone who helps develop Concrete5 that might be able to offer some guidance? THis is literally stopping me from launching a site. I'd really rather not waste the money I've already invested in Concrete5 (and time for that matter) and have to look at another product...but I am truly at a dead end here. I don't know what else to do.

If anyone has experienced this problem, it would truly be great to hear from you, so that I can fix this issue and get this site live.

Thank you very much for your time.
mkly replied on at Permalink Reply
mkly
Hello,
I work at concrete5. The problem you are describing is very odd. There is nothing in concrete5 that directs a browser to port 8888. I really mean that. Therefore I'm trying to help you figure out what might be doing that. This is very commonly a server(Apache, htaccess) configuration issue.

Best Wishes,
Mike
concreteart replied on at Permalink Reply
mkly,

Thank you very much for your reply. Is there something particular/specific details I should ask my webhost to provide (i.e., specific information about the server set up), to verify that my server is set up properly from their end?

I am on a server that runs LiteSpeed.
mkly replied on at Permalink Reply
mkly
If you have ssh access I would run this command from the shell, or have your host do it.

grep -Rn '8888' *


And see if you can find the 8888, but that's a pretty far shot in the dark. But you might get lucky.

Best Wishes,
Mike
concreteart replied on at Permalink Reply
Hi mkly,

Just wanted to let you know that the webhost enabled SSH access so we're working on setting that up now. They will not run the command for us as they said it is not a server issue since they said their test index.html file worked just fine with the SSL certificate.

As soon as we can get the SSH access set up, I will reply back with results after running that command.

Thank you!
concreteart replied on at Permalink Reply
Hi mkly,

I ran the command you listed above and have a ton of information that came up. What would you like me to post here to review? I did search for all lines that refer to port 8888, but I'm not sure what that tells us.

Please just let me know.

Thank you
-concreteart
concreteart replied on at Permalink Reply
mkly,

After more closely looking through the results, I've found two instances that might be the problem:

public_html/files/backups/dbu_1362879231.sql:7044: ,('BASE_URL_SSL','2012-10-29 12:45:45','https://localhost:8888',0,0)

www/files/backups/dbu_1362879231.sql:7044: ,('BASE_URL_SSL','2012-10-29 12:45:45','https://localhost:8888',0,0)


There are other references to 8888 dealing with "we have a memcache servers mem1,mem2 on port 8888," in a number of places...
mkly replied on at Permalink Best Answer Reply
mkly
Ok, now we're getting somewhere. I'm not sure when or what set that in your database(we got lucky and it showed up in your backups) but lets take that out.

If you have access to the database and am comfortable making changes to it you want to go to the "Config" table and look for the "cfKey" column with a value of "BASE_URL_SSL". Looks like that is probably 'https://localhost:8888'. Delete that one record completely. Please make a backup before doing this.

If you aren't comfortable doing that, let me know and I can write you a quick tools file that can automate that.

With that gone it should fall back to it's default setting.

Best Wishes,
Mike
concreteart replied on at Permalink Reply
Mike, thank you!!!!

I found the Config table and deleted the BASE_URL_SSL (after doing a proper backup), which was listed as https: //localhost:8888

Now it seems to stay https: when I visit my site. It just says it's partially encrypted, so I'll have to figure that out, but this issue has finally been resolved!!!

Thank you so much!
-concreteart
mkly replied on at Permalink Reply
mkly
Great to hear it.

Best Wishes,
Mike