Increase upload file size limit

Permalink 6 users found helpful
I need to increase the maximum file size upload limit from 2mb. When I try to upload anything larger I get the error message...

An unknown error occurred while uploading the file. Please check that file uploads are enabled, and that your file does not exceed the size of the post_max_size or upload_max_filesize variables.

Where do I look to change the variables of post_max_size and upload_max_filesize?

I don't want to upload via FTP, rather increase this file size limit. Any help would be greatly appreciated!

View Replies:
Remo replied on at Permalink Reply
That's not related to Concrete5 but rather php, check your php.ini file and search for these variables..
jelthure replied on at Permalink Reply
also depending on your host you may be able to set these values in your .htaccess file
AWCwebmaster replied on at Permalink Reply
I don't know if you ever got this sorted, but for future reference, you can do this with a php.ini file.

Paste this into a plain text editor...
upload_max_filesize = 20M ;
post_max_size = 20M ;
max_execution_time = 60 ;

... and save the file as "php.ini" (or "php4.ini" if the default version on the server is PHP5 and you are using PHP4). Upload it to your public root (e.g. public_html, www, home, etc) and it will increase the maximum upload to 20MB, and timeout to 60 seconds. You can adjust the numbers to suit.

keegle replied on at Permalink Reply
I already have a php.ini file in there and it states "This is the default settings file for new PHP installations.
; By default, PHP installs itself with a configuration suitable for
; development purposes, and *NOT* for production purposes".

So now I have created a new php.ini file that reads " upload_max_filesize = 20M ;
post_max_size = 20M ;max_execution_time = 60 ;”

The one I found is in the root folder public_html/

I need to know how to handle this. Any help would be great at this point. I need my max upload file size to be much larger than 20 or even 100Mb.
pvernaglia replied on at Permalink Reply 1 Attachment
You may be struggling with limitations your provider has on your server. If you run the attached file, test.php it will tell you all the PHP setting and what the loaded configuration file is. If you have access to the configuration file just change the values as the others here have suggested. If you can not access that file then you need a php.ini in the directory where Concrete5 is installed. You may need to name that file php.ini, php4.ini or php5.ini the test.php page will tell you when you have your configuration loaded.

If you can't get it to change it is a question for your hosting companies support as it is a server issue.
mobiledataforce replied on at Permalink Reply
I added the following to my php.ini file and nothing changed. When I added it to my php5.ini file, I finally got some results.

post_max_size = 80M
file_uploads = On
upload_max_filesize = 80M

This sets the limit to 80MB.

Thanks, Tim
bhurley1904 replied on at Permalink Reply
I am at my ends with this. I have tried everything in this thread for DAYS and I have not got it to work.

Changed php.ini (php5) on my server as mentioned in this thread. I am using a simple form for uploading files. It will upload most files except mp3 for some reason. Also, it won't upload files more than 15M even though I have it set to 120M.

When I test my uploader, it shows a progress percent bar and looks fine all the way to 99% then displays "HTTP Error"

I am going crazy, any new suggestions? Thanks in advance.

(my experience in web design is novice; I'm trying though)
mobiledataforce replied on at Permalink Reply
I tried to set mine higher than 80mb... to like 120mb and it didn't like that setting. I got it to work at 80mb, so I stopped poking the bee's nest and just left it there... So far, I haven't needed more.

So, you might want to see if a lower number would work for you.

Good luck!
bhurley1904 replied on at Permalink Reply
Thanks for your reply. I tried 80mb, but I still have the same issue. It was worth a try though.

I will continue trying different things and stay within the 80mb range like you suggested. That is all I should really need too.
pvernaglia replied on at Permalink Reply
Try setting post_max_size a little larger than upload_max_filesize
bhurley1904 replied on at Permalink Reply
Okay I gave it several attempts. I changed the numbers to reflect 40M 50M 75M etc. with no effects. I also tried setting post max larger than upload size. As far as I can tell, my server has no restrictions on file upload size. My php.ini is completely editable.

No matter what, I can not upload a file much larger than 10Mb.....uhhggg it is really frustrating.

Thanks for your replies; however, I surrender. It looks like I'm gonna have to get my server's help desk on the horn....uhhggggg again.
mobiledataforce replied on at Permalink Reply
I would just like to reiterate that when I changed my php.ini file, I got zero results like you're getting. However, when I modified my php5.ini file, I started seeing some change in my upload limit.

I hope this helps.

Tim (MobileDataForce)
curtis07 replied on at Permalink Reply
Try what I figured out in this thread:
jero replied on at Permalink Reply
Try creating a php file like this


Among other things, it will tell you the path of the php.ini it's actually using, which isn't always where you might think it is. It may also list other folders that it checks for overrides. Once you've found these, add the values you need.
jfhencken replied on at Permalink Reply
You can go to
Dashboard » System & Settings » Environment Information
and check the values for:

post_max_size - 10M
upload_max_filesize - 10M

I have a site on ( which runs PHP v5.4.19

First I placed the following lines in a php5.ini file and placed it in /public_html and that had no effect.

file_uploads = On
upload_max_filesize = 100M
post_max_size = 100M
upload_tmp_dir = /tmp/

Next I changed the file name from php5.ini to php.ini and everything worked fine. A recheck of the Environment Info then read:

post_max_size – 100M
upload_max_filesize - 100M
sykesdev replied on at Permalink Reply
Hi Folks,

You need to reload the config.

e.g. on CentOS
service httpd reload
yfsneals replied on at Permalink Reply
Nope. Didn't like that. Got an error message: pdo not found.
usedearplugs replied on at Permalink Reply
There are a lot of factors at play in this. My guess is that the following is your problem, you might be using the wrong PHP INI setting.... Are you using the Classic PHP setting, a SINGLE PHP file setting, or Fast CGI? If you're not using the classic setting, then you may be editing a php.ini file that is being ignored.

The following URL shows how to change it on Blue Host... Your host will be different.