Increasing file upload size limit

Permalink 1 user found helpful
Is there a way to increase the max file size you can upload through the file manager. I need to upload 1/2 hr sermons to the site and they are too big even at a low bitrate.

If there is no way to do this is there another way that would be easy for my clients. Thanks!

joemalleck
View Replies:
Remo replied on at Permalink Reply
Remo
I hope not!

If every user could increase this limit, the php guys could remove this parameter completely.

The server admin wants and can change this parameter. On some hosting offers you can create a per site php.ini file but still something you have to do by ftp and no in c5 interface.
joemalleck replied on at Permalink Reply
joemalleck
Cool. We'll just upload through FTP and link to the file.

Thanks
nforcer replied on at Permalink Reply
nforcer
Put this:

php_value upload_max_filesize 20M
php_value post_max_size 20M
php_value max_execution_time 200
php_value max_input_time 200

into an .htaccess file in the root directory.
20M is 20MB, so you could change it to what YOU need for this upload.
The other lines are for the timelimit and execution time. Should work. For more things that can be changed this way check out the php documentation. http://www.php.net/manual/en/ini.php#ini.list...

If you do not want this anymore after the upload, just remove the lines from the .htaccess.
mikegoodwin replied on at Permalink Reply
mikegoodwin
Hi

I gave this a try but had no luck. When I check the site I am greeted with this message

"Internal Server Error"

There is much more to the message but I get the feeling that this would be enough info. My htaccess file already has the code to enable php5. I have it as in the file as follows

AddType x-mapp-php5 .php

suggested entries is there anything more I should have to do? As you can tell I am pretty dam green at this. Thanks for any help.
elyon replied on at Permalink Reply
elyon
Depending on your server, they may not allow changes to the file upload limit.

If you have access to FTP, you can upload files into the /files/incoming directory. Then when you go to the file manager and click "more" at the upper-right, you can select the files you uploaded there.
mikegoodwin replied on at Permalink Reply
mikegoodwin
I gave that a shot but could not find the folder. Any ideas? I tried looking at the location of the thumbnails that are used in the default site and could not locate them either. I have checked in the properties for the folder locations but I am at a loss as to where these folders are. Again any help is greatly appreciated.
mikegoodwin replied on at Permalink Reply
mikegoodwin
Got this working. I simply had to create the /files/incoming folder. I am pretty certain that I tried this before replying the last time. I am thinking it may have been a typo on my part.

Thanks for the help!
fastcrash replied on at Permalink Reply
fastcrash
cool.. concrete5 already handle this matter.
very impressive.
babyfeet replied on at Permalink Reply
I see no "more" button anywhere on the file manager page, section. Please advise.
Pixelfixer replied on at Permalink Reply
Pixelfixer
I think this has changed since the "more" option was available. Here's the new method:

1) Upload your files via ftp to the "/files/incoming" folder. (you may first need to create an "incoming" folder beneath your "files" folder)
2) From within "File Manager", click on "Upload Multiple" in the upper right corner.
3) Click on the "Add Incoming" tab
4) From here, select the files you want to move into the database and optionally check the box next to "Remove files from incoming/directory" when finished.

Hope this helps
Johnny4x replied on at Permalink Reply
.. just come across this problem.. its brilliant that C5 has work arounds for this kind of thing!

Thanks for the tip!