Index Search Engine getting stuck

Permalink 1 user found helpful
In version 5.4 - Whenever the Index Search Engine job is run, it runs infinitely. I've looked through the forums, and only found a solution to stop the job (by updating its status to ENABLED in the database) but I'm curious if anyone has experienced anything similar and what the root cause is. The job has completed successfully before, and no real major changes have been made sense... any ideas?

hursey013
View Replies: View Best Answer
Mnkras replied on at Permalink Reply
Mnkras
working fine for me here
hursey013 replied on at Permalink Reply
hursey013
[Fri Apr 09 11:30:44 2010] [error] [client 68.84.204.53] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 5784 bytes) in /var/www/vhosts/pimasheriff.org/httpdocs/concrete/libraries/3rdparty/Zend/Cache/Core.php on line 348, referer: http://pimasheriff.org/index.php/dashboard/system/jobs/
hursey013 replied on at Permalink Reply
hursey013
Well I doubled the memory_limit in my php.ini and that seemed to do the trick... seems like a lot of memory is needed for the index search job.
adobetoby replied on at Permalink Reply
adobetoby
Would you detail out a few steps on how to do that?

Thanks in advance.
hursey013 replied on at Permalink Best Answer Reply
hursey013
There's a couple different ways. If you have access to your php.ini file, find the line memory_limit = 16M and double the value to 32M or 64M (or possibly more depending on your needs).

The other way to do it is in the .htaccess file in the root of your website. In there you can add the line php_value memory_limit 16M and increase the value there.

More info -http://drupal.org/node/29268
bshea replied on at Permalink Reply
how do I do this from dashboard. new to this. thanks
Mnkras replied on at Permalink Reply
Mnkras
you can't do it from the dashboard, you can probbably ask your host to do it,
bshea replied on at Permalink Reply
got that done thank. how do i stop the - Index Search Engine- from spinning and restart it or turn it off?

Thank you.
bshea replied on at Permalink Reply
does the site run slow for you?
thirdstreetflats.com
adobetoby replied on at Permalink Reply
adobetoby
I am having the same problem
goldfish replied on at Permalink Reply
goldfish
After I increased the memory limit, I needed to to follow the instruction here to restart the search index:
http://www.concrete5.org/community/forums/usage/unable_to_access_pa...
Just edit the Jobs table and set jStatus to 'ENABLED', then run again from the Dashboard. Once I did that it indexed several hundred pages in 15 minutes.
izzetcinar replied on at Permalink Reply
how do you set the jstatus to 'ENABLED'? I am at /concrete/tools/jobs.php and I am running 5.4.1.
invision replied on at Permalink Reply
invision
I'm experiencing the same problem. I ran phpinfo and it shows my server has 512mb reserved for PHP, so that may not be the issue.

I'm on a shared hosting account -- could that 512mb be for the entire server (all the sites)? Or is it for my instance of PHP? I'll have to contact my host and find out.

**UPDATE** tech support at my host say that 512mb is reserved for my instance of PHP, not the whole server.

I can interrupt the process by changing the value in MySQL, but I'm not sure the pages are getting indexed.