Issues with cached content when moving concrete5 site from dev site to production url

Permalink
I recently developed a site on a seperate concrete 5 install at dev.example.com.

Everything was working fine until we decided to make it live. Any block that containes an image that was set to crop automatically (a few were created with Designer Content), don't appear and the site haults and stops loading from there.

This is what I have tried
Clear the Cache from the Dashboard
Delete the contents of the files/cache folder
Delete the contents of the files/tmp folder

Restored site from an earlier version and tried again with the same result.

The best I can think is that some where in the cache it's looking for old data and failing when it cant find the data.

Concrete5 is set to show errors but it shows none, there are now new errors in error_log.

All cache settings are turned off.
concrete5 Version - 5.6.3.1
PHP Version - 5.4.29

Please Advise!
Thanks!

View Replies:
Ale replied on at Permalink Reply
Does the server have GD library installed? GD is required for image cropping and the lack of GD usually throws error and stops page load.

Also, if you want to clear all cache contents, find a database table called collectionversionblockoutputcache (or something similar, can't remember the exact name now) and remove all rows from it (truncate).
bw1 replied on at Permalink Reply
I have confirmed with phpinfo and a small gd php test that gd is installed an working to the best of my knowledge.

I have started to comment lines out to try and figure out the issue it appears to be in any block I have created with Designer Content that has an image field set to Crop and Fit and specfic dimentions.

In the controller it generated this line:
public function view() {
      $this->set('field_3_image', (empty($this->field_3_image_fID) ? null : $this->get_image_object($this->field_3_image_fID, 436, 270, true)));
   }


If I comment out the line in the view function the rest of my page loads (without the image - - makes sense) but I can't figure out why.

I have created a new block all together to test it, different images etc. it still happens.

Any ideas?
Ale replied on at Permalink Reply
Is the files folder writable on your production server?
bw1 replied on at Permalink Reply
Yes, the files directory is 755, which I've also compared with other sites I have. They appear to be set the same.