Layouts works only if you logged in

Permalink 1 user found helpful
I made new site yesterday on version 8.4.3. There's no styles for layouts for some reason if you're not logged in. Those styles contains stuff like:
#ccm-layout-column-wrapper-20 div.ccm-layout-column {
width: 20%;
}
So everything looks broken. How do I fix this?

2 Attachments

View Replies:
MaestroEspantoso replied on at Permalink Reply
I disabled cache and it helped. I don't get it. Is this a bug?
tommyh replied on at Permalink Reply 5 Attachments
tommyh
I am having a similar issue with Layouts logged in vs. not logged in as admin. In edit mode, they display correctly. When the page is published but still logged in as admin, looks correct as well (see edit mode 1,2,3 and Correct View images attached). Exit the dashboard admin to view the site not logged in and the 5 columns stack rather than column 5 across (see incorrect view). Currently set as Freeform Layout for this area. I know that freeform is core so maybe the community can help me. I tried to use the bootstrap layout block tool and it does not space 5 columns evenly across the block area. Any ideas here?
FlappyHands replied on at Permalink Reply
FlappyHands
I am having the same issue. Weirdly, after saving the page and publishing it the first time I refresh from a standard page not logged in to concrete it loads correctly, but only once. If you refresh again it breaks the layout of a lot of things and on top of that it also breaks my google maps block!

Not impressed.
FlappyHands replied on at Permalink Reply
FlappyHands
I have a solution! At least it works for me. Fixes both the Google Maps issue and broken layouts issue.

Go to your cache settings in System & Settings and turn block caching off completely. For some reason the block caching seems to be breaking both blocks and layouts right now.

It worked for me. Good luck, folks.