Mail smpt and Bluehost

I have a site on bluehost, Using the registration for c5 sign up with email verify. I set c5 for external smtp and filled the correct info, i believe. But I get an error that rejected from sending, the sending is [email protected], I need it to be [email protected] as the from address, how can I change this or is there another setting I am missing.


View Replies:
ntgross replied on at Permalink Reply
Bluehost blocks port 25 to help reduce spamming from their servers. Try using "phpmail" instead of an external SMTP server.
mojoburns replied on at Permalink Reply
Is there actually a way around this? Having the same problem and using the PHP Mail function works but has the bluehost box address not the email address and looks odd. Any help appreciated:)
ld13 replied on at Permalink Reply
hi mojoburns,
Have you find a solution for this problem? I hate the bluehostbox thing on the emails! thank you.
codingpenguins replied on at Permalink Reply
Thanks for giving life to a year old thread ; ) There is what I did to ensure all emails came from one set email. Make a change to "concrete/helpers/mail.php" before $mail->setFrom I added

$from[0] = "[email protected]";
$from[1] = "admin";

Hope this helps - all emails will say this
ld13 replied on at Permalink Reply
Thank so much fro replying, I tried your suggestion, but I did not work, if I use the external SMTP I wont receive the emails and using the regular email function it still will show the weird bluehostbox email!
codingpenguins replied on at Permalink Reply
I am sending using the normal php mail sender. What kind of emails are you sending, I only test for confirmation emails? I am also using bluehost and this prevented the bluehostbox from address.

EDIT: Did you make sure you put this code BEFORE the setFrom?

EDIT: What does the from email say? before the bluehostbox?
MyVMC replied on at Permalink Reply
Thank you. Your solution worked perfectly for me!
asaucier replied on at Permalink Reply
Does anyone know where to make this change in 5.6?

concrete/helpers/mail.php does not have settings anymore...

MyVMC replied on at Permalink Reply
After a recent upgrade to l am back to the mailer problem where Bluehost is showing up as in the from address. Can anyone help?

MyVMC replied on at Permalink Reply
If you upgraded to a newer version of Concrete5, you may have lost this functionality. The fix for me was to make sure I duplicated the mail.php file.
So make a copy of your mail.php file…

from: (This is where the original file that work now reside)

to: (This directory might be empty right now)

WARNING: your paths might be a little different than mines, so just look for the two "Helpers" directories and make the necessary changes.

Hope this helps others with the same problem.