Mysteriously can't login

Permalink
I am very puzzled about a site login process. This is a simple site, no login modules installed. On my local machine, everything is fine. The online site is the exact copy of the local one. I imported the local database.

The local login works, not the online installation...

I receive no error message. The login process seems to operate since when pressing the connect button, I go from
http://yvansabourin.com/login
to
http://yvansabourin.com/index.php/login/do_login/...

And I can't reset the password. No mail is sent, no confirmation of sending something is shown...

Any idea?

GuyVerville
View Replies:
mhawke replied on at Permalink Reply
mhawke
A couple of questions/thoughts...

What theme are you using? Some themes weren't built with the proper mechanism to display all the error messages. This includes the core themes supplied with C5.

Were "Pretty URL's" enabled on your local site? If so, you might have to turn them off by opening the 'config' table and setting the 'URL_REWRITING' value to '0' (zero).

Did you bring over the .htaccess file from your localhost site? If so, try renaming it on your production site and creating a blank .htaccess file for now. To see if that helps.

There are ways to reset the admin password but let's see if the above suggestions get you in first.
GuyVerville replied on at Permalink Reply
GuyVerville
Thank you for answering.

The theme is mine, nothing coded about showing errors. What I do not understand is that the site is working perfectly on my local machine.

I have commented the paths in site_theme_paths.php to return to the core login page. I get then this weird error: a user name and a password are required. But i DO give those. And if I want to reset, the valid email address I give is refused.

I have indeed removed the .htaccess file to be sure it was not the culprit.

I have also tried the methods shown elsewhere to reset the password. This didn't help either.
mhawke replied on at Permalink Reply
mhawke
If you look in your 'users' table, do you have a user with a uID of '1'?
mhawke replied on at Permalink Reply
mhawke
Try adding this line just above the "print $innerContent;" line in your view.php. You will need to edit your 'config/site_theme_paths.php' file again to point to your theme.

<div class="alert alert-error"><?php Loader::element('system_errors', array('error'  => $error));?></div>


This line will display more system errors.
GuyVerville replied on at Permalink Reply 1 Attachment
GuyVerville
I get the same error as described. It seems that the form is not passed...
GuyVerville replied on at Permalink Reply
GuyVerville
Yes, admin user has an id of '1'
mhawke replied on at Permalink Reply
mhawke
What happens if you edit the 'config' table to set URL_WRITING to zero?
GuyVerville replied on at Permalink Reply
GuyVerville
Nothing... and Url-rewriting is still running. I am lost... perhaps something with the host provider...
mhawke replied on at Permalink Reply
mhawke
Is there a public URL I could look at?
GuyVerville replied on at Permalink Reply
GuyVerville
Yes, it was given above:http://www.yvansabourin.com
mhawke replied on at Permalink Reply
mhawke
Are you absolutely sure you're connected to the right database?
GuyVerville replied on at Permalink Reply
GuyVerville
There is only one database here. I will try create a new database, just in case.
mhawke replied on at Permalink Reply
mhawke
No don't bother, it will only confuse things.
mhawke replied on at Permalink Reply
mhawke
Just so I'm clear, the value of URL_REWRITING in the config table is currently set to '0' and you have a blank .htaccess file in your root directory?

Also, try deleting everything inside the '[root]/files/cache' folder (leaving an empty 'cache' folder)
GuyVerville replied on at Permalink Reply
GuyVerville
Yes, I've done all that. The database is the right one. I have delete it, no site, recreate it, site on again.

This is probably something very silly to correct, but I don't see it. And nothing is written in the database, no log. The information is simply not passed. First time it this sort of things happens to me.
pvernaglia replied on at Permalink Reply
pvernaglia
I would first try copying all the files from the local machine up to the live site again and see if that corrects it. If it doesn't, try sending the password reset again, if you do not get it look at the Logs table in the db, there should be an entry there with the details of the message and the password reset link, try that link to reset the password.
GuyVerville replied on at Permalink Reply
GuyVerville
Strange enough, the problem disappeared by itself. The only thing I did is to level up the permissions of the file directory, which was 755 to 777... Go figure.
mhawke replied on at Permalink Reply
mhawke
My files folder is set to 755.

I'm wondering if your host has some sort of caching enabled or some 'cloud' services going on. Nothing in your source code indicates this to me but the behaviour seems suspicious.