New install But can't use custom themes? WTF?

Hi Team, I just did a fresh install and set-up a web site.
# concrete5 Version
I downloaded a blank html5 template and uploaded the the theme folder.

Now it installed correctly, BUT DOESN'T WORK?
File /home/ADMINanimepro/www/concrete/themes/test/default.php not found. All themes need default.php and view.php files in them. Consult concrete5 documentation on how to create these files.

It was copied and installed into the theme/ folder not root/theme? Why is it looking their?

I have tried these files on over installs and they work fine? And have tried moving themes I have working onto the new site same error?

Some one please advise me What the hell is going on here? I have looked in the DB but can't find the relevant location to change the theme locations?

View Replies:
exchangecore replied on at Permalink Reply
Did you install your concrete5 website into a concrete directory? Generally I would frown upon doing so since it makes things a bit ambiguous and hard to troubleshoot. I'm also not sure if it causes problems (wouldn't think so but i dunno).

In the event that your install isn't in a concrete directory, it would appear that those files are missing or you don't have the appropriate read access to them and furthermore you shouldn't be adding themes to the concrete directory if it isn't your root install directory. Double check that those files exist and that you have read access to them.
carl101lee replied on at Permalink Reply
Hi Their

I have been building themes for concrete5 for 4 years almost. I know where they go and how they work.

My Issue is that some how the new install of concrete5 seems is looking in the wrong place?
The theme is in the /theme folder, the install is in the root ftp(no sub folders)
Now it detects the theme in the install themes section and installs it, but does work when activated because of the error listed above.

Now if I download a package theme and input in the package directory then install the theme it works. But if I put any theme direct into the theme folder it doesn't work and can't see the files /view.php as it is looking in /concrete/themes not /themes?

Now I installed the theme then token a copy of the theme and placed it into the /concrete5/theme/mytheme after installing the theme from the /theme directory and it now finds the files and works?

Where in the database does it tell the theme where to look when it installs as this is the error?

I think I might know how this happens as I did a fresh install and then un-installed all the root themes before installing the new one? maybe this confused it? Not having an active theme?

JohntheFish replied on at Permalink Reply
A long shot: maybe disable and clear the overrides cache while installing and setting up the theme.
carl101lee replied on at Permalink Reply
Hi John

Thanks for idea, but this was one of the 1st things I tried.

I also did a manually removal of the cache via ftp just to try and have disabled all cache

No luck..

I think ill just fresh install before I do any more work on it.

andrewjaff replied on at Permalink Reply
carl101lee replied on at Permalink Reply
Hi Their.

Just for you I downloaded one of the templates unzipped and installed in the theme DIR same error.

This I believe is a BUG I have ever found or created some how? Not Me..

I bet if I just do a fresh install and don't un-install the root themes I have no issues.

Deladroid replied on at Permalink Reply
Did you ever get this figured out? I am having the same issue and it's driving me crazy.

I moved a site over to a new server, and no matter what I do (fresh install, copied over exactly, or what) it still will not allow me to use the custom theme now.
terano replied on at Permalink Reply
Clearing the cache via Dashboard helped for me. Fortunately I could still load the Dashboard