"No input file specified" error

Permalink
I just restored my site from a server-based backup of the site, following a meltdown during an upgrade to 5.4.2.2.

My problem now is that all of the pages except for the home page throw the error "No input file specified" when navigating to the page. The site ishttp://skoop.com.

From the Dashboard/Sitemap I can Visit any of the "missing" pages, and they are correct. The Canonical URLs are correct. But when navigating to those pages on the live site (even in Edit mode while logged in as Admin) I get the "No input file specified" error.

Any ideas on this?

View Replies: View Best Answer
prober996 replied on at Permalink Reply
When I turn off Pretty URLs the problem goes away. But this worked before the meltdown, and the .htaccess file has the correct code in it etc.

Ideas?
nteaviation replied on at Permalink Reply
nteaviation
My first guess would be a directory and/or file permissions issue. Sometimes on a backup restore the permissions get set incorrectly. Also check that your .htaccess file is readable by your apache/webserver user.

Clearing C5 caches is something else to try.

If you manually upgraded be sure to
•Go tohttp://www.yoursite.com/index.php/tools/required/upgrade... (Note: if this does not work, tryhttp://www.yoursite.com/index.php/tools/required/upgrade.php)...
thephilm replied on at Permalink Reply
thephilm
I know with GoDaddy that you typically need a php5.ini file (seehttp://www.concrete5.org/documentation/how-tos/developers/concrete5...

I'd double check to make sure that the file moved over.
prober996 replied on at Permalink Best Answer Reply
After two days of head-banging, playing with htaccess, php5.ini, etc.... the problem turned out to be that PHP was configured to run in FastCGI mode, instead of as an Apache module. Making that one change solved the problem.

Many thanks to all of you who offered me your advice and wisdom.
toitojose replied on at Permalink Reply
please help me!! I have the same problem in this page:www.www.galapagosandesamazon.com,... I can navigate in subpages but I cannot enter on the login page ("No input file specified.") so I cannot login, I cannot edit
creativeorange replied on at Permalink Reply
creativeorange
This might help me a lot. I am a designer and far from an experienced coder. Any advise on how I can change the apache issue on GoDaddy? I've been having to host this site (mhbphoto-graf.com) on GoDaddy and it's been one blunder after another.

With Pretty URLs on, everything breaks however the Superfish won't adapt to non-prettyURLs when turned off so it naturally gives me 500 errors.

Any help would be awesome!
Thanks!
division100 replied on at Permalink Reply
How did you change the settings to disable FastCGI ??? Is that somewhere in the CMS config file? Or changeable in index.php ???
leestrayer replied on at Permalink Reply
Apparently you have pretty urls running now on your site, and we're having a hell of a time on Godaddy. What did you do to get things going again?
paulb323 replied on at Permalink Reply
If it's any help to anyone, I had the same issue trying to install C5 with Godaddy hosting.

They have a instructional page here https://support.godaddy.com/help/article/4675/manually-installing-co...

I was still facing issues after following until I fixed one simple thing...

The php file in my root folder was called "php.ini". When I renamed it to "php5.ini" (also having made the recommended changes), the issue resolved itself. Simple things, eh!
datacraftsteve replied on at Permalink Reply
datacraftsteve
I'm having the "No input file specified" error too but in my case a little more drastic.

I'm using c5 ver 5.7.3.1 and had to manually install in bluehost as their one click install wouldn't even start.

I started with the theme, Elements and started to play around with no problems. Then decided I needed more so I purchased theme, Fundamental. Installation went well and the installed home page, blog, about worked okay.

Then I set Pretty URLs, went to the home page and started changing some settings. So far okay.

Then I tried to go to the site map and I got the No Input File Specified error. In fact, I get this error no matter where I try to go to. System, any page, site map, etc. Only the home page works. So, I cannot turn pretty urls off.

Any suggestions?

I'm not one that can code so hopefully, there is an easy way to fix this.

Thanks,
Steve
datacraftsteve replied on at Permalink Reply
datacraftsteve
Problem resolved by my ISP, Bluehost.

Here's what the support guy sent me and did for me:

http://stackoverflow.com/questions/6118740/codeigniter-no-input-fil...
I was reading through this, and tried this suggestion
Just add the ? sign after index.php in the .htaccess file :

RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$
jasteele12 replied on at Permalink Reply
jasteele12
Just came across this on iPage.com hosting and concrete5 5.4.2.2 - in case somebody else comes across this strange problem.

Added this instead of the last line by @datacraftsteve above:

RewriteRule ^(.*)$ index.php?/$1 [L]
jsantaga replied on at Permalink Reply
jsantaga
Hey jasteele12,

Just had to shout out and say this also worked for me in 5.4.2.2. Thanks for posting this as the typical .htaccess and prettyURL settings were not working for me and my concrete5 install inside of a subdirectory.

- Jordan
jasteele12 replied on at Permalink Reply
jasteele12
Hi Jordan,

Glad to hear it helped. I've been thinking about building a public database of hosting, PHP versions, FastCGI/mod_php, Ngnix and Apache configurations.

I've come across quite a few - and most are not fun trying to figure out what the problem is. Sometimes it's not even pretty URL related.

Can you add what hosting provider (and any other details) in case anyone else runs into this problem (more food for the search engines ;)

Thanks - John
jegra replied on at Permalink Reply
Thanks, jasteele12 - this also worked for me. Am running the site locally, off a Win 10 MAMP environment.
jasteele12 replied on at Permalink Reply
jasteele12
You're welcome jegra.

I'm guessing you meant WAMP (MAMP is normally for Macs)? Can you tell us which stack you installed, since there are quite a few out there now.

Thanks, John
jegra replied on at Permalink Reply
Hi John,

No, it is, actually, MAMP -- they make a version for Windows as well. It gives the ability to host multiple versions of PHP, which is a feature I was looking for. Details on the environment:

MAMP Pro 3.3
- PHP 5.6.28 (for production compatibility)
- MySQL 5.6.34

Concrete5: 5.6.3.5

Thanks again,
Joe
jasteele12 replied on at Permalink Reply
jasteele12
Hi Joe,

Thanks for the details. This *will* help someone in the future, I'm sure.
nzhome replied on at Permalink Reply
I had the same problem with my hosting company changing something (OpenHost) without telling me. in the end i just went into the Concrete5 dashboard and clicked "Sitewide Settings" on the left menu. and then unticked "pretty URLS" and ticked "disable cache" and the "No input file specified" problem went away.. problem solved.