Notification Email from Forms

Permalink 2 users found helpful
I have tried to find the answer in the forums but have not found a decent answer yet. None of the forms on my site send a notification email to me when a form is submitted. I have checked and my host(Yahoo) supports the mail() function and looks like it's set up to be used. Here is the error I get in the logs:

Mail Exception Occurred. Unable to send mail: Unable to send mail
#0 /concrete/libraries/3rdparty/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /concrete/libraries/3rdparty/Zend/Mail.php(973): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /concrete/helpers/mail.php(227): Zend_Mail->send(NULL)
#3 /concrete/controllers/login.php(434): MailHelper->sendMail()
#4 [internal function]: LoginController->forgot_password()
#5 /concrete/libraries/controller.php(190): call_user_func_array(Array, Array)
#6 /concrete/libraries/controller.php(169): Controller->runTask('forgot_password', Array)
#7 /concrete/libraries/view.php(600): Controller->setupAndRun()
#8 /concrete/dispatcher.php(246): View->render(Object(Page))
#9 /index.php(2): require('/concrete/dispa...')
#10 {main}
Template Used: forgot_password
To: [email protected]
From: "Forgot Password" <[email protected]>
Subject: Forgot Password

Here are the instructions from Yahoo on how to setup mail():

Before you can send email with Perl or PHP, you must complete the PHP/Perl Mail Setup process. To begin setting up PHP/Perl mail, click the "PHP/Perl Mail" link on the Create & Update or Index tabs of your Web Hosting Control Panel. The mail setup process allows you to customize the email address that users will see when you send them a message (for example, "From: [email protected]").

You will also need to indicate the path to the Yahoo! mail program, Sendmail. The path to Sendmail is /usr/sbin/sendmail.

The only thing I didn't do is the last paragraph sendmail path. I'm not sure where to put that.
Can anybody help me? I'm not a programmer, more of a designer so specific instructions please.

pakigreenl
View Replies: View Best Answer
jgarcia replied on at Permalink Reply
jgarcia
Typically the default sendmail path in PHP is already set to /usr/sbin/sendmail, so it's strange that they would tell you to set this manually.

Are you familiar with setting up a phpinfo page? Just create a file on your server called phpinfo.php. In it, put



and fire it up in a browser. You should see a line under PHP Core that says "sendmail_path". If the value for this is not /usr/sbin/sendmail, then that's where the problem is and you'll need to change the ini setting.
pakigreenl replied on at Permalink Reply
pakigreenl
I just tried that, but it's not displaying any info.
pakigreenl replied on at Permalink Reply
pakigreenl
Forgot the opening and closing tags... duh. Checking info now.
pakigreenl replied on at Permalink Reply
pakigreenl
Here's what I got:

/usr/sbin/sendmail -t -i

a little different than what yahoo asked for. I don't know if it matters.
Brainakazariua replied on at Permalink Best Answer Reply
Brainakazariua
That looks fine

Judging from the previous posts you did this:
Under your Yahoo Web Hosting account, go to Web Hosting Control Panel > Create & Update > php/perl mail setup.

I believe in the attempt to restrict spamming, Yahoo requires all PHP mails to specify a from: address that is in your own domain.

basicly this means you need to make sure the form/password forgotten mail adresses are defined to be of your own domain.
The basic is that these are send from the Admin adres.
You can change these by adding the following to your site.php:
define('FORM_BLOCK_SENDER_EMAIL', [email protected]');
define('EMAIL_ADDRESS_FORGOT_PASSWORD', [email protected]');


The to adres you can specify under the form itself.

Yahoo itself gives this as a guide:http://help.yahoo.com/l/us/yahoo/smallbusiness/webhosting/php/php-1...
pakigreenl replied on at Permalink Reply
pakigreenl
Thanks that was spot on.
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
I have a client who is having this exact same problem. Where exactly do I go to make the change?
pakigreenl replied on at Permalink Reply
pakigreenl
Add to your site.php file where your database info is. It's in the root. Let me know if you don't find it.
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
I can't find it. I, too have a client hosted with Yahoo!. Walk me through the steps on how you get to the site.php file that needs to be edited. I'm lost.
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
Ok, I found the database directory, and it is not there at all. It's not in the root directory, either.
pakigreenl replied on at Permalink Reply 1 Attachment
pakigreenl
Look in the config folder. It is right below the concrete folder. See the attached jpg of my Firefox ftp addon.
pakigreenl replied on at Permalink Reply
pakigreenl
Basically, Log in to the site via your ftp client. Find all the folder containing the Concrete files. Find the Config folder. Site.php is in the Config folder. Open the file and add the code in between the PHP tags. That's it.
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
Thanks! That helped! I fixed it and now the forms work!
pakigreenl replied on at Permalink Reply
pakigreenl
Glad I could help.
blokeybloke replied on at Permalink Reply
Hi I have the same problem, I do not recieve any form notification emails.

My website ishttp://www.akhter.co.uk

If you look athttp://www.akhter.co.uk/phpinfo.php... it seems i have not set up the mail criteria and this is where I am stuck to what to do.

If i check the my.ini file I do not see any mail settings there. I take it this is where they are stored?

It is on our company web server which is windows sever 2008 / iis 7 I have had to manually install PHP, Apache and MySql.

The website was designed by a web designer who created it on a Linux based server with Heart Internet so asking him technical questions regarding mysql apache etc. is not really an option

When i look at my control panel on the server I do not see any mail settings to create or edit

I could do with a walkthrough to fix this

Regards

Steve
growlrooed replied on at Permalink Reply
growlrooed
Where in cc5.7 would I post this? I'm getting that same problem. I need to not be listed on form return addresses.