Open an external link in new window NOT working

Permalink 2 users found helpful
I have a page created that is supposed to open an external link in a new window, but it doesn't open a new window. The page is on the second level in the drop down menu. I have Superfish 1.1.4 installed. Can you help? I've uploaded a screen capture of the linking external page window.

1 Attachment

wanderlust
View Replies:
madeforspace replied on at Permalink Reply
madeforspace
Have you tried adding /"target="_blank to the end of your URL?

Hope that helps
wanderlust replied on at Permalink Reply
wanderlust
I tried this. A new window now opens up and first I get a "404 Error - page not found". but then it opens to an obscure page.
could it be that the ordering of the url is incorrect. This is what I have.

https://id34108.securedata.net/glimmerglass/donate_now_order.html/&q...
FatTony1952 replied on at Permalink Reply
FatTony1952
Any solution to this? Mine aren't working either. Seems like when you check the 'Open in new window', that it would add the _blank tag. You shouldn't have to add it manually.
nteaviation replied on at Permalink Reply
nteaviation
Wanderlust:
I clicked your link and got
http://id34108.securedata.net/glimmerglass/donate_now_order.html/%22target=%22_blank

Your URL is messed up.
FatTony1952 replied on at Permalink Reply
FatTony1952
nteaviation - I'll interject here: when you add an external link to your nav, you get three fields, one is the name of your link, the other is the actual url, the other is whether you want it to open in a new window.

The field for your link gets the
<a href""></a>
automatically by the system. The issue is that the "target=_blank" isn't being stored with the link or it just isn't recognizing that it's suppose to have it. Of course, this is assuming that it gets built automatically with the href tag.
wanderlust replied on at Permalink Reply 1 Attachment
wanderlust
I have also noticed that if you want an image in an image block to link to an external page, that opens in a new window, that the "target=_blank" isn't working properly their either. I added it to the end of my URL and I get the same thing that happens when I tried to open a new window using the drop down menu.

The only time I seem to be able to get anything to link properly and open in a new window is if I link it through a content block. There is a 'lock and unlock' link tool in the menu bar (to the left of the anchor tool) that allows you to put in your url and then there is a pull down menu giving you options on how you want the link to behave. This is the only place where I can get 'open in a new window' to function properly. But it still doesn't obviously solve the initial problem.
marcusmorris replied on at Permalink Reply
This is messy but it worked for me. When you enter the url, c5 wraps it in double-quotes, right? So what you enter is the url followed by ONE set of double-quotes, followed by a space, followed by target="_blank (with no double-quote at the end).

Your first double-quote replaces the one c5 would have used to mark the end of the url, your second double-quote marks the beginning of the attribute for target and c5 obligingly and unwittingly adds the final quote to mark the end of the attribute! What a palaver!

If you're going to use this though, keep an eye on it. If the omission is ever fixed in future versions of c5 then this cheap hack is likely to stop working!
jamesfinn replied on at Permalink Reply
jamesfinn
@marcusmorris:
IT WORKED! Dude, you are awesome!
andrew replied on at Permalink Reply
andrew
Superfish may not have been updated to honor the "open in new window" parameter, which we added more recently than we did the superfish menu.
andrew replied on at Permalink Reply
andrew
I will cross-post this in the superfish add-on support area.
FatTony1952 replied on at Permalink Reply
FatTony1952
I'm not using Superfish. I'm actually using just a CSS menu and the AutoNav block for my menu. The pages I'm referring to are also in a Page List and those won't open up in a new window either.
andrew replied on at Permalink Reply
andrew
To the original poster: I would open a support ticket in the superfish add-on support section. We will get back to it as quickly as we can.