wrong path after moving to production server

Permalink
I developed my site on my local machine setup with WAMP. Everything works fine on the dev server and <?php echo $this->getThemePath();?> resolves to /mysticfitness/themes/mystic_theme.

I now moved the site to hostmonster to go live. While most things are working I noticed a lot of broken image links. The element inspector shows that <?php echo $this->getThemePath();?> still resolves to /mysticfitness/themes/mystic_theme but I think it should resolve to mysticfitness.com/themes/mystic_theme or just /themes/mystic_theme? I ftp's all the files under mysticfitness to public_html. The concrete5 version is 5.6.1.2.

I can find the images at:
mysticfitness.com/themes/mystic_theme/images/
for example:
mysticfitness.com/themes/mystic_theme/images/yoga_dancer_d.png

I tried to hard code this path into the header file (for one image) but to my surprise the element inspector still shows the old path - how can that be?

I tried most of the ideas I could find on the forum but still can't get getThemePath to resolve correctly. Any ideas on how to fix this would be greatly appreciated. If you want to look the URL ishttp://www.mysticfitness.com.

View Replies:
Blenderite replied on at Permalink Reply
Blenderite
Ok, something definitely went wrong with the transfer. You said that you can see all the images when you go to the folder containing them?

You should log into edit mode and try to edit the images that are not showing up and try deselecting them from your images folder. Do this to one or two and then Publish. If it fixes it, then open the page in chrome or firefox and right click > Inspect Element. Check and see if there are any differences in what you see for the one that you just fixed and the ones that still are not working. You may be able to see a very slight difference between them.

Also, in my opinion, I would change the font from Comic Sans to something else. Comic Sans is not a good font to use for a business web page. It is often seen as a childish, juvenile font. Just my opinion...

-Blenderite
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
You can disable the pretty URL, the clear your cache & then re enable it. Hope it will solve your problem.

Rony
FischerVision replied on at Permalink Reply
FischerVision
Check you Base URL in your site.php in the config folder.
concreteton1 replied on at Permalink Reply
Thank you all for your help. I finally figured out what was wrong. I tried hard coding the path in the php file and the path still resolved wrong. I realized that the image must be getting it's path from somewhere else. Sure enough I went into edit mode on the concrete5 site and edited the block with the image in it. The block was an HTML block where I pasted a bunch of code and sure enough that is where the hard coded path was wrong. Sorry rookie mistake!