Pretty URL issue

Permalink
I have an issue with the "Pretty URL" option.

When I tick the "Pretty URL" box and Save, I get this error message :

It was not possible to detect your server kind. Here's the configuration sections for every supported server: please manually add the one relevant for you to your server configuration.

And then they give me a code :
>>> For Apache <<<
<IfModule mod_rewrite.c>
   RewriteEngine On
   RewriteBase /
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME}/index.html !-f
   RewriteCond %{REQUEST_FILENAME}/index.php !-f
   RewriteRule . index.php [L]
</IfModule>
>>> For nginx <<<
location / {
   try_files $uri $uri/ /index.php?$query_string;
}


It is unclear to me what I should do exactly to get the Pretty URL functioning.
I am a marketing guy, not an html or web expert, so please explain me with simple words. :) I am afraid of ruining the whole website if I am doing things uncorrectly.

Thanks a lot for your help
Olivier

View Replies: View Best Answer
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
What is your website address?
It is easy to discover your webserver type using the whois database search facility.
wollastoni replied on at Permalink Reply
https://www.veturgences-rennes.fr
ConcreteOwl replied on at Permalink Best Answer Reply
ConcreteOwl
In the root of your site you should have an .htaccess file, edit the file and past this code into it and then save the file.
<IfModule mod_rewrite.c>
   RewriteEngine On
   RewriteBase /
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME}/index.html !-f
   RewriteCond %{REQUEST_FILENAME}/index.php !-f
   RewriteRule . index.php [L]
</IfModule>
wollastoni replied on at Permalink Reply
Thank you : it has half way worked... :)

Now url without index.php work.

BUT I still get the same error message when I click on Pretty URL.
And the website still display index.php by default, and don't remove it automatically :
See an example here :https://www.veturgences-rennes.fr/index.php/numero-urgences...

Any idea ?
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
Clear your concrete5 cache and your browser cache
bitit replied on at Permalink Reply
bitit
I have the same problem , have try to delete the cache, but don't work

http://www.otticamaremmi.com

i have concrete5-8.5.1

Enrico
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
This being caused by your canonical url.
Change it from this
<link rel="canonical" href="http://www.otticamaremmi.com/index-php">

To this
<link rel="canonical" href="http://www.otticamaremmi.com">
bitit replied on at Permalink Reply 1 Attachment
bitit
where i can work around for change this setting?

i have this
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
Hmm...
Looks like you have created a folder called index-php and installed your site in that folder.
This has nothing to do with pretty urls because pretty urls works to hide the index.php (index[dot]php) part of the url.
You have index-php (index[dash]php) which is not a file name it is a file path.
So, I can only think that you have a folder named index-php which is what you are seeing in your url links
bitit replied on at Permalink Reply
bitit
well, maybe the mistake is that have rename the home page like index.php, and so i have create a folder index-php;
so the question is , how call Home page? if i desire will be index.php and not index-php
in the same time , i will try to change the path in the others page.

Enrico
bitit replied on at Permalink Reply 2 Attachments
bitit
i have solved in in this way ,
is correct?
ConcreteOwl replied on at Permalink Reply 1 Attachment
ConcreteOwl
I have attached an image showing the settings for my test site home page ...
bitit replied on at Permalink Reply
bitit
ok, and what's happening if you typehttp://conc853/index.php
??