Pretty URLs and rewriting an .htaccess file....almost but not quite helping!

I have posted a question about Pretty URLs (under Dashboard > Systems and Settings). My question was why is my url static when I click each of my pages...why aren't my pages showing up as .org/page? The answer I received on this forum was use Pretty URLs, which I did. But that didn't work - so I called my web host, HostGator.

They said I'd have to add code to the .htaccess file which I found my my file directory (public_html > .htaccess). When I opened that up it looked like this:

1.DirectoryIndes iframe.html
3.AddHandler audio/mpeg .mp3
4.AddHandler audio/mpeg .mpeg
5.AddHandler audio/mpeg .mov
6.AddHandler audio/mpeg .mpeg4
7.AddHandler audio/mpeg .m4v

The HostGator rep told me to go back to my Pretty URLs box and find the code that it created (I hadn't noticed it before, but there it was!). I copied and pasted the code into the top line of the .htaccess file like he suggested - but I'm still not getting the individual pages to show up in my urls. The .htaccess file now looks like this. Does anyone have any ideas as to what I'm doing wrong?

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /concrete5.5.2.1/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
DirectoryIndex iframe.html

AddHandler audio/mpeg .mp3
AddHandler audio/mpeg .mpeg
AddHandler audio/mpeg .mov
AddHandler audio/mpeg .mpeg4
AddHandler audio/mpeg .m4v

thank you!

View Replies:
Jongosi replied on at Permalink Reply
Hi nutmeats, make a copy of your .htaccess file, clear it out and then put this content in it:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ index.php/$1 [L]
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

Let's see if that works. Also, make sure that pretty URLs is enabled in the dashboard.

Your C5 installation should be in /public_html/. So when you look in the public_html directory, you should see all the C5 directories, like blocks, concrete, config, etc. Is that right?
nutmeats replied on at Permalink Reply
Hi there,

I wanted to post a follow-up message to my problem of a static URL. The problem was that my URL was not changing whenever I clicked on any of my pages. Jongosi posted a response that - technically - should have worked, and eventually did.

Here's what happened: My Concrete5.5.2.1 folder was buried in my public_html folder. Hence my url was mysite/org/concrete5.5.2.1. I called my web hosting company, Hostgator, to ask them to make my site and my URL the same. They did this but the way they did it was by creating an iFrame with a re-direct to my Concrete site. Technically they did what I asked but my site wasn't my 'true' domain.

That's why all of my inquiries here weren't working, and I'm not so technically minded that I would have known an iFrame from a hole in the wall.

It took subsequent calls to Hostgator to have them move my files 'up' in the directory - just the same as you would on your normal desktop folder structure. The only difference was the customer service representative at Hostgator had to adjust a file after the transfer, but now all is fine.

If anyone else has issues with static URLs....look for an iFrame and call your hosting company!