Private Messaging -- HELP!

Permalink 1 user found helpful
Hello all,

I really want to add the private-messaging option to the member's page of my website (greatmaze.co.cc), but i have absolutely no idea how to do that.

I have the latest version installed with everything on its default setting, but I have enabled Public Profiles and email.

How do I enable private messaging? Any help would be really appreciated.
Thanks!

View Replies: View Best Answer
okhayat replied on at Permalink Reply 1 Attachment
okhayat
Logged in users can private message each other through their profile pages.
If you view a user's profile, you'll find the 'Send Private Message' link on the left. Click on that and you'll get the form to do so.
BenjaminRH replied on at Permalink Reply
Thanks for the quick response.

I tried that however, and there is no such link.
okhayat replied on at Permalink Reply
okhayat
Just make sure the user you're trying to send doesn't have the 'I would like to receive private messages.' attribute disabled.
BenjaminRH replied on at Permalink Reply
Oh -- that attribute doesn't exist. How do I remake it?
okhayat replied on at Permalink Reply 1 Attachment
okhayat
It should be in Dashboard -> Users & Groups -> User Attributes
If not, just add it with the information in the attached screenshot.
naaturalinstinct replied on at Permalink Reply
naaturalinstinct
AWESOMMMMMMMMMMMMMMMMMMMMMMMME! Thanks!
glockops replied on at Permalink Reply
glockops
I also have a new 5.4.1.1 install and do not have any user attributes by default. Perhaps they are only configured if "sample content" is installed?

There is another attribute that is not mentioned here:
"Send me email notifications when I receive a private message." with the handle of "profile_private_messages_notification_enabled"

I'm going to post this as a bug, if you also did not have these two attributes installed by default, please confirm the bug.
fastcrash replied on at Permalink Reply
fastcrash
the bug already mention by Mnkras.

see here
http://www.concrete5.org/index.php?cID=105481...
jeepinjane replied on at Permalink Reply
I am also missing the compose Message link. Using 5.4.1.1 and have added the attributes as mentioned in this thread. Is there something else I need to do to activate this link on Friends pages?
BenjaminRH replied on at Permalink Best Answer Reply
Just to close this off, I followed everything okhayat said, and my pm system is now working.

Thanks so much!
fastcrash replied on at Permalink Reply
fastcrash
hi benjamin, i follow what okhayat said, but still no private messages link. i look into another profile too, there is no link 'Send Private Messagess'

i use concrete5 5.4.1.1
thank all, okhayat.
okhayat replied on at Permalink Reply 1 Attachment
okhayat
Ok. Just to clear things out. Uptill version 5.4.0.5 the user attribute 'profile_private_messages_enabled' was still there, so the option to send a private message was available if the user allowed so.
Starting with 5.4.1 the attribute was not there anymore, so you need to add it yourself.
So, if you're using C5 5.4.1 and later here's what you have to do:
1. Goto Dashboard -> Users & Groups -> User Attributes
2. Add a new 'Checkbox' attribute
3. User the attached att1.png to fill in the needed information
4. Save the attribute
Once done, any one who has this attribute set, will be able to receive PMs.
To test it, add a new dummy user, to goto the members page, and choose that user. You'll see the option 'Send Private Message' on the side.
Hope this makes sense.
jeepinjane replied on at Permalink Reply
After installing this attribute correctly, the link has appeared. Thank you!
dlanoue replied on at Permalink Reply
I entered this attribute as described. However only new users created have it enabled. I've tried to edit each user (existing) and enabled the check box via the Edit User screen and then updated each user but the Send Message links still do not show up. ALso in the user's profile screen there is no indication thet it has been enabled.
JRick replied on at Permalink Reply
JRick
did you ever figure this out? I am having the same issue... all my old users aren't seeing it but i added a new test user and it is showing now.
dlanoue replied on at Permalink Reply
Yes. There are two attributes that previous threads indicated you have to add. Once that is done any NEW user will have those attributes as they are activated. For any existing users you have to go into each of their profiles and ENABLE both of the attributes for them one at a time. In my case I only had about 2 dozen users to update. Once they were updated the "Private Message" links appeared.
dlanoue replied on at Permalink Reply
Oh. I forgot one thing. The Enable function in the profile is somewhat confusing. First you have to click on the "text" part of the attribute and then go over to the icon on the right side of the attribute and click the icon that looks like a Pen & Paper. If done correctly then the attributes will indicate a "Yes" in the block. That should be it.
JRick replied on at Permalink Reply
JRick
Thanks for the reply, I actually got it all figured out late last night and forgot to mention it on here... Everything seems to be working alright now. Next I get to try and tackle the issue of not receiving messages when someone registers. I saw some threads on that earlier so hopefully I'll get it figured out from those.

Thanks again.
artninja replied on at Permalink Reply
Yeah, well I did all this and the Private message link still isn't showing up. Any other suggestions?
dlanoue replied on at Permalink Reply
You need to follow this thread: okhayat replied on Jan 21, 2011 at 6:51 am

It's found several threads above this one. Remember to download the att1.png file so you can see the screen shot. There are several attributes that you need to install yourself. Then follow the rest of the threads. It does work!
artninja replied on at Permalink Reply
I got it right after I posted. I had to go back through and reset everyone's attributes.
zoinks replied on at Permalink Reply
I followed the png and there's no link showing up.
tgtg replied on at Permalink Reply
I found the page, where i can send PM.
B/c the link shows up on different page, i was expecting it on the profile main page.
zoinks replied on at Permalink Reply
I have done the following:

1. Goto Dashboard -> Users & Groups -> User Attributes
2. Add a new 'Checkbox' attribute
3. User the attached att1.png to fill in the needed information
4. Save the attribute

...but there is no link at the left.

I created a new user AFTER I did the above steps and I saw the checkbox clicked, but when I go to the Members page, I don't see the link.
tgtg replied on at Permalink Reply
search a member, if you have one or create a member and
When you search, you will find a member, click that found member and you will see the SEND PM link.

Hope this will help.
zoinks replied on at Permalink Reply
THANK YOU!!! If I could mark your answer as green for "best answer," I would. Wow. So, here's a feature that needs to be better documented...