Probleme Cache CSS

Permalink
Hello
I have a big problem with the new concrete 5

The cache is disable but my css is creating everytime in files/cache/css
(pages also)

And with firebug I can see :
<link rel="stylesheet" type="text/css" href="/files/cache/css/so/main.css" />


Infact the code is :
<link rel="stylesheet" type="text/css" href="<?php  echo $this->getStyleSheet('main.css')?>" />


Then, of course, I can't work correctly..
When I cahnge something in css, it never appears, even if I purge the cache, or delete directly on the server.

I never meet this before with previously version.

What can I do ?

Thank you



# concrete5 Version
5.6.1

# concrete5 Packages
Galleria image gallery (2.0), Gallery (1.8), Login (1.1), Page Auto Redirect (1.2), Simple Image Gallery (1.1.3), So (1.0.3).

# concrete5 Overrides
None

# Server Software
Apache/2.2

# Server API
cgi-fcgi

# PHP Version
5.3.10

# PHP Extensions
calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, fileinfo, filter, gd, gettext, hash, iconv, intl, json, libxml, mbstring, mcrypt, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_pgsql, pgsql, Phar, posix, Reflection, session, SimpleXML, SPL, standard, tokenizer, xml, xmlreader, xmlwriter, zlib.

# PHP Settings
max_execution_time - 120
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 128M
post_max_size - 64M
safe_mode - Off
safe_mode_exec_dir - /usr/local/php/bin
safe_mode_gid - Off
safe_mode_include_dir - <i>no value</i>
sql.safe_mode - Off
upload_max_filesize - 64M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pgsql.max_links - Unlimited
pgsql.max_persistent - Unlimited
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
safe_mode_allowed_env_vars - PHP_
safe_mode_protected_env_vars - LD_LIBRARY_PATH

Elstud
View Replies:
mhawke replied on at Permalink Reply
mhawke
As far as I know, that's how it's supposed to work. I have many sites on 5.6.1 and I have the same files in my cache and I have no problems seeing changes to css immediately. Is your C5 caching all turned off? Is your browser's cache turned off? Try refreshing your browser with CTRL+SHFT+'R'

When I make a change in my css file and re-load the page, the timestamp on the css file in the cache shows a refreshed version.
slafleche replied on at Permalink Reply
slafleche
1 - Make sure it's not your browser, clear your history, cookies, and cache
2 - Clear concrete's cache, in the System and Settings section

3 - If that still doesn't work, you can add "?v=1" to your css path:
<link rel="stylesheet" href="css/style.css?v=1">
Elstud replied on at Permalink Reply
Elstud
Tank you every body, it's ok now.
I am a stupid guy ans I was very tired.
I worked on a copy folder with the same name on a second disk and my FTP was on the other one.. then ...