Problems moving a concrete5 file (on server) to my computer (local)

I've been following this how-to:

But when I try to view my concrete5 site on my computer I am getting a very unhelpful error message:

An unexpected error occurred.
An error occurred while processing this request.

So I'm not even sure where to start as to fixing this. I suspect it might have something to do with a package I installed, but not sure...


Okay looks like I had to go to exceptions.php and change this line:

View::renderError(t('An unexpected error occurred.'), t('An error occurred while processing this request.'), $e);

to this:

View::renderError(t('An unexpected error occurred.'), $e->getMessage(), $e);

1 Attachment

View Replies: View Best Answer
dzimney replied on at Permalink Reply
My first thought on this is that the site is having trouble connecting to the database. I would check and recheck your database configurations in /config/site.php and ensure they are set to connect to your local database instance.

It's also possible that you're running into permissions issues with you're local copy, but I would think that's unlikely.
nicolechung replied on at Permalink Reply
Oh, I **kind** of figured out what it was...but not sure how to fix it going forward.

Basically, even though it's a small site, the DB is too big for phpMyAdmin to import. I tried changing the upload_max_filesize settings in my php.ini, but when I imported a whole bunch of tables were missing.
Blenderite replied on at Permalink Reply
I keep having this problem too. I need to find a solution for this.
nicolechung replied on at Permalink Reply
Yeah if you find one, let me know.

Does it work better if you import via Terminal? (I'm on a MAC)
JohntheFish replied on at Permalink Reply
The database backup sql file is a text file. You can open it in a text editor and split it into pieces, then import the pieces in phpMyAdmin.

If you use Backup Voodoo for the online backup, one of the custom settings is to save each backup pass into a separate sql file. Another settings group is to reduce tables (like monster page statistics), so providing another way to get the sql file down to a manageable size.
dzimney replied on at Permalink Reply
Similarly, you can updated your server configurations (php.ini) to allow for larger file uploads. You'll want to change the second of the following lines to whatever size you think you'll need.

; Maximum allowed size for uploaded files.
upload_max_filesize = 32M

Another possible solution is to adjust the php settings through your .htaccess file, however this will only work if your server is configured to allow it. Here's the equivalent code for htaccess:

php_flag upload_max_filesize "32M"
nicolechung replied on at Permalink Reply
See, I changed my max upload size (as shown) but when I imported the file into phpMyAdmin it doesn't give an indicator as to when it is I think I might have interrupted the process.

I did end up opening the .sql file in Sublime and copying-pasting it in parts. Maybe I will continue with that method...
weyboat replied on at Permalink Reply
phpMyAdmin can accept database files as a zipped file, I usually zip up my database files before importing to phpMyAdmin...
Blenderite replied on at Permalink Reply 1 Attachment
I tried that. This is what I got.
pushpopstudio replied on at Permalink Best Answer Reply
The request might have timed out. You can extend the execution time with the following:

php_value max_execution_time 300
nicolechung replied on at Permalink Reply
I think try

show grants for username

Where "username" is the username set up for that database. It should say something like

ronyDdeveloper replied on at Permalink Reply
I've had the problem same mysql importing before but then I consider SQLyog for this importing. It is a great software and it has a free edition as well. It takes time for importing & exporting but there is neither worry about max_execution_time nor max_upload_filesize. So you can upload any size of file.

Note: It takes time to execute maybe quite frustrating sometime to wait for a long, but its secure.