Redirect to user profile page on login

Permalink
Hi, folks.

I'm trying to get my site to run so that users will go straight to their user profiles upon login. In the "Where to send users on login?" section of the Users and Groups > Login & Registration page, I have selected the Member profile option. I have public profiles enabled. But no matter what, every login - user or admin - takes me to the site's home page.

What am I doing wrong?

campbell
View Replies:
campbell replied on at Permalink Reply
campbell
Hm, nevermind.

This functionality did end up working, though I don't know what I did to get it working properly.

I did drink a lot of coffee, so maybe that's it.

1. Enable public profiles.
2. Select "Member profile" option in "Where to send users on login?" section.
3. Drink lots of coffee.
4. Profit.
LucasAnderson replied on at Permalink Reply
LucasAnderson
I don't see a ??? step?
Responsive replied on at Permalink Reply
Responsive
I am too having troubles with this and have tried drinking coffee but does not work. Anyone had this problem when using the Login block ?

I have turned on the setThemeByPath in the site_theme_paths.php but don't think this should be the cause. Please help anyone !!
LucasAnderson replied on at Permalink Reply
LucasAnderson
Have you:

1. Enabled Public Profiles?

2. Selected "Member Profile" in Sitewide Settings > Login & Registration?
Responsive replied on at Permalink Reply 2 Attachments
Responsive
Yep have both items checked , see attached screen prints
Responsive replied on at Permalink Reply
Responsive
Sorry , it was the a setting in the login block that was causing the problem. Thanks for the help anyway
primewaydesign replied on at Permalink Reply
primewaydesign
Thanks a lot!