Remove author picker from page attributes

Permalink
Hello,

I am looking for a solution to hide the Author picker from page settings attributes. Everytime i try to open this attributes page with a editor account i get a warning pop up that says permission denied. I think because the group can see any users or get a list with users.

Does anybody have a clue how i can remove this field or grant the permissions to view the users for a specific group?

I hope somebody is able to help me.

mikeJK
View Replies:
hutman replied on at Permalink Reply
hutman
If you go to Dashboard -> System & Settings -> User Permissions you can grant permissions for "Access User Search" to a group.
mikeJK replied on at Permalink Reply
mikeJK
Thanks for your answer. Unfortunately this doesn't solve the problem. If I grant the access to search users I still get the error when I open the page attributes. Can it maybe be somewhere else?
hutman replied on at Permalink Reply
hutman
Can you put an image of what you're seeing? I'm not sure I understand what you're seeing.
mikeJK replied on at Permalink Reply 1 Attachment
mikeJK
This is the message I get when I try to open the page attributes of a page.
hutman replied on at Permalink Reply
hutman
Does this message pop up as soon as you open the attributes panel, or after you click on the select user bar?
mikeJK replied on at Permalink Reply
mikeJK
As soon as i open the attributes page.
hutman replied on at Permalink Reply
hutman
If you check the page properties does this group have "Edit Properties" permissions? I don't think this error would show up if the issue was only for editing one specific field.
mikeJK replied on at Permalink Reply 1 Attachment
mikeJK
I have made a new screen shot with more debug output to check what the problem could be. I will attach the image with this post.

All the groups have permissions to edit the page.
hutman replied on at Permalink Reply
hutman
So looking at line 96 of /concrete/controllers/backend/user.php (which is what's throwing the error) it shows that this user doesn't have permissions to View any users. So if you go into Dashboard -> System & Settings -> User Permissions I believe the one that needs to be enabled is either "View User Attributes" or "Access Group Search"
mikeJK replied on at Permalink Reply
mikeJK
I've enabled all the permissions for this specific group, but still the same error is thrown.
hutman replied on at Permalink Reply
hutman
Did you clear the cache after you made those changes?
mikeJK replied on at Permalink Reply
mikeJK
Yes I did and it didn't work. Still the same error.
hutman replied on at Permalink Reply
hutman
What version are you using?
What permissions does the user have on the page?

I'm going to try to replicate it on my local server and see if I can figure out what's going on for you.
mikeJK replied on at Permalink Reply 1 Attachment
mikeJK
This are the permissions for every page. The users of group superusers are not getting the permission denied error. Only the editors group.
hutman replied on at Permalink Reply
hutman
That's very odd. I setup a site with Version 8.2 with those same permissions (no other permissions setup) and I don't get that error

What version are you using?