site errors / pretty URL issue

Permalink
Hey there,

We have a web site located athttp://quartzsitervshow.com/ and I set it up years ago and don't touch it unless the content editors have a problem. today, none of the 2nd level pages were workign and I got a "no input file" eror. After some google searches, I disabled pretty URLs and things are workign again, but with longer links.

help needed fixing the root issue! Please help...thanks!

Here is the code in the pretty url window:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>

here is the environment info:
# concrete5 Version
5.5.2.1

# concrete5 Packages
OfficeSpace Theme (1.5.1), Stickies (1.2.3).

# concrete5 Overrides
None

# Server Software
Apache

# Server API
cgi-fcgi

# PHP Version
5.3.29

# PHP Extensions
bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, filter, ftp, gd, gettext, gmp, hash, iconv, imap, ionCube Loader, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, mysqlnd, openssl, pcntl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, readline, Reflection, session, shmop, SimpleXML, sockets, SPL, sqlite3, standard, suhosin, tokenizer, xml, xmlreader, xmlwriter, Zend Guard Loader, zip, zlib.

# PHP Settings
log_errors_max_len - 1024
max_execution_time - 5
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - -1
max_input_vars - 1000
memory_limit - 128M
post_max_size - 8M
safe_mode - Off
safe_mode_exec_dir - <i>no value</i>
safe_mode_gid - Off
safe_mode_include_dir - <i>no value</i>
sql.safe_mode - Off
upload_max_filesize - 2M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
safe_mode_allowed_env_vars - PHP_
safe_mode_protected_env_vars - LD_LIBRARY_PATH
suhosin.cookie.max_array_depth - 50
suhosin.cookie.max_array_index_length - 64
suhosin.cookie.max_name_length - 64
suhosin.cookie.max_totalname_length - 256
suhosin.cookie.max_value_length - 10000
suhosin.cookie.max_vars - 100
suhosin.executor.include.max_traversal - 0
suhosin.executor.max_depth - 0
suhosin.get.max_array_depth - 50
suhosin.get.max_array_index_length - 64
suhosin.get.max_name_length - 64
suhosin.get.max_totalname_length - 256
suhosin.get.max_value_length - 512
suhosin.get.max_vars - 100
suhosin.log.phpscript.is_safe - Off
suhosin.memory_limit - 0
suhosin.post.max_array_depth - 50
suhosin.post.max_array_index_length - 64
suhosin.post.max_name_length - 64
suhosin.post.max_totalname_length - 256
suhosin.post.max_value_length - 1000000
suhosin.post.max_vars - 1000
suhosin.request.max_array_depth - 50
suhosin.request.max_array_index_length - 64
suhosin.request.max_totalname_length - 256
suhosin.request.max_value_length - 1000000
suhosin.request.max_varname_length - 64
suhosin.request.max_vars - 1000
suhosin.session.max_id_length - 128
suhosin.upload.max_uploads - 25

View Replies: View Best Answer
jero replied on at Permalink Reply
jero
Has your hosting provided made any changes recently? It might be worth asking that question.

You could try changing
RewriteRule . index.php [L]

to
RewriteRule ^(.*)$ index.php?/$1 [L]


I've had to do that on some sites where the standard rewrite code does not work - usually a Plesk based system.
stewblack23 replied on at Permalink Best Answer Reply
stewblack23
Call your web hosting and ask what settings should be used for your .htaccess file. They might have updated there servers which might effect the .htaccess file that C5 needs for pretty URL's.
quartzsitervshow replied on at Permalink Reply
Thank you Stew and Jero. It indeed was a change at the host and they fixed it for us. Thank you very muc for your feedback.