Stack Spacing

Permalink
Hi All

I am loving the new stacks, great idea and I have not lost my beloved scrapbook or a stack of one as they now are.

My question is this:
I have a stack that I want to add to a sidebar on multiple pages that has four blocks in it. I want to add some space between the blocks so in the stack I have added the space in Design area for each block. The stack shows the space no problem but when I add the stack to a page the space disappears.

Anyone have any ideas or suggestions?

Cheers

Alex

madeforspace
View Replies:
guythomas replied on at Permalink Reply
guythomas
I noticed the same earlier in the week. Any CSS you define on the individual blocks within the stack is not rendered when the stack is rendered on a page. You can confirm this bug here:
http://www.concrete5.org/developers/bugs/5-5-0/custom-block-css-doe...

-Guy
madeforspace replied on at Permalink Reply
madeforspace
Thanks Guy
mhawke replied on at Permalink Reply 1 Attachment
mhawke
Has this been fixed yet? On the bug tracker link you mention, Andrew claims to have fixed it in Github around Jan 14th but I just swapped my files for the ones at Github (dated Jan 27th-ish) and the problem is still there. Any background images or css added to blocks in the stacks doesn't get added to the destination page. Kind of makes them useless to me because if I have to mess with a stack each time I insert it on the page, I might as well just build it from scratch on each page.

Also, a minor annoyance... some of my stacks are wide and they overflow the stacks dialog box. Not a very polished UI. (See attached screenshot)
stretchrt replied on at Permalink Reply
stretchrt
I need this CSS bug fixed ASAP too as I'm working on some new pages using stacks, and I can't do any CSS styling on them without as you say messing around with them on each page, which is pointless.
andrew replied on at Permalink Reply
andrew
Again, as I mentioned in another post, this bug was addressed in 5.5.1. If you're still not seeing CSS apply to your stack you need to a) make sure you've upgraded b) investigate why your theme might be interfering with this CSS. If you're using a core theme it's possible that some of the theme styling is interfering in some way – but as you can see from screenshots I've posted in other topics in this thread, styles are most definitely being included on the page. I'm going to need more information as well as a link to your site and administrator access to see whether something is or isn't working.
andrew replied on at Permalink Reply 2 Attachments
andrew
Hmm. There may be something in your theme that keeps the styles from accepting custom styles, or you may not have fully applied the update, because this is working better in 5.5.1. Please try and replicate this problem in a trial account here:http://www.concrete5.org/about/trial/...

I have attached images to this post demonstrating how I'm attempting to reproduce this bug.
mhawke replied on at Permalink Reply
mhawke
Andrew, I can confirm your suspicions regarding an incomplete upgrade however I thought I was following an approved (safer?) upgrade method. I put the new 5.5.1 core files into a concrete5.5.1 folder in the upgrades folder (so I ended up with a tree like this: root/upgrades/concrete5.5.1/concrete/etc/etc) and added "define('DIRNAME_APP_UPDATED', 'concrete5.5.1');" to my site.php.

When I actually followed the more accepted upgrade method and replaced the concrete folder on my site with the concrete folder from the 5.5.1 archive (and comment out the define statement in site.php) then the stacks work as designed.
andrew replied on at Permalink Reply
andrew
That is a safer method. I'm not sure why that particular update isn't working for you.
stretchrt replied on at Permalink Reply
stretchrt
Andrew, like mhawke I just followed the standard update procedure, which resulted in having the 5.5.1 files in a folder under updates, with the "define('DIRNAME_APP_UPDATED', 'concrete5.5.1');" added to site.php. If there's anything different I should have done, please let me know.

WRT to CSS, I could reproduce what you did easily enough, but what I have done is define a css class for the blocks in the stack, with the intent of styling them in my main.css, but inspecting the stack elements when added to the page, I see no sign of these css classes I had defined for the blocks.
andrew replied on at Permalink Reply
andrew
Ah, interesting. It's possible that custom CSS is working but the code for the "class" isn't. I will check this out.
andrew replied on at Permalink Reply 4 Attachments
andrew
Actually, I just checked on 5.5.1 and I can't replicate what you're saying. Please check out my screenshots. If I've missed something please let me know.

Screenshot 1: Specifying ID and class on a block in a stack
Screenshot 2: Adding the stack to a page
Screenshot 3: Seeing the ID referenced in the header
Screenshot 4: Seeing the HTML with the block, including both the custom ID and the custom CSS class.
stretchrt replied on at Permalink Reply
stretchrt
that's odd, they do appear to be there now, can't say for sure now whether it was not working yesterday, or my eyes were tricking me. Thanks for all your help getting it sorted anyhow.
digirunt replied on at Permalink Reply
digirunt
Prehaps you could use this for now..

http://www.concrete5.org/marketplace/addons/spacer/...

and insert them in between your blocks in the stack. I have found this a useful addon in the past and it avoids hacky solutions for the time being.