User group can't add new subpages: page not found error

Permalink
First of all – hi. Second: I'm sorry if this is in the wrong forum.

Down to business.

I am building a small website for a non-profit organization. Everything's been going well, but I am having trouble with the blog section.

I have a main blog page that has a list of all of its subpages (the actual blog posts). I turned on advanced permissions and allowed "editors" group to only add new sub pages to "Blog" main page, which seems to work fine up until the point when I login as the user and try to add a new page (= blog entry under Blog). After selecting add new page site redirects me to 404 Page not found error page.

I can add pages just fine with the main admin account, but it'd be good to restrict the permissions of other users as much as possible since the users may/will not be very tech savvy. I can't find anythign on this subject on Google... information on 5.7 is pretty scarce in general.

// I actually found another topic that seems to be close to my issue:https://www.concrete5.org/community/forums/5-7-discussion/add-sub-pa...

except I didn't allow registration – I added a new user manually and assigned it to "Editors" group. I also don't need the user to be able to view the sitemap, just to add subpages under the page "Blog".


Permissions I've given:

BLOG MAIN PAGE PERMISSIONS: manual permissions, subpages inherit permissions
add sub page: "admin", "editors", everything else just "admin"

PAGE TYPE PERMISSIONS for page type "blog entry":
PERMISSIONS FOR THIS PAGE TYPE — add this type pages: admin, "editors"
PERMISSIONS FOR ALL PAGES OF THIS TYPE — edit attributes, edit content, delete, accept changes, add subpages: "editors"

DRAFTS PERMISSIONS — add subpages: "editors"

Should I give more permissions or..? I'm lost.

View Replies:
hutman replied on at Permalink Reply
hutman
I'm able to replicate this same behavior, but I am not able to find out what to change to fix it. Looking through the forums there are several other issues that are the same that were not resolved as well, perhaps you should report a bug.

https://www.concrete5.org/developers/bugs/5-7-4/...
shaijis replied on at Permalink Reply
Thank you for your reply! I really hope this'll be fixed soon. The whole 'blog where organization's members can post to' was such a nice idea and I already promised it to the client....

Btw, I also tried giving the permissions to one specific user instead of user group, but it resulted in the same thing. So frustrating.
gerry63 replied on at Permalink Reply
I had the same problem.

I solved it by setting permissions on DRAFTS to the following:

View Editors
View Versions Editors
View Page in Sitemap Editors
Preview Page As User Administrators
Edit Properties Administrators
Edit Contents Editors
Edit Speed Settings Administrators
Change Theme Administrators
Change Page Template Administrators
Edit Page Type None
Edit Permissions Administrators
Delete Editors
Delete Versions Administrators
Approve Changes Editors
Add Sub-Page Editors
Move or Copy Page Administrators
Schedule Guest Access Administrators
Edit Multilingual Settings Administrators

The permission causing the trouble seems to be View Versions. If set to Administrators, the 404 error occurs. Setting to Editors or whatever the custom group is called, clears the problem.