Too many redirects issue

Permalink
Hello Everyone,

I keep getting the too many redirects issue, sometimes during login to concrete5 sometimes during logout.

On opening it in incognito mode it works fine, during logout it causes issue.

I have checked in other browser's too, but still face similar issue.

Have tried clearing browser, concrete5 cache but still the issue exists

Pretty URL's are turned off.

Below is the environment

# concrete5 Version
Core Version - 8.5.0
Version Installed - 8.5.0
Database Version - 20190301133300

# concrete5 Packages
Color Carousel (1.0), Designer Content (4.0), Figma (1.0.1), Personas (1.0.1), Quick Tabs (1.0), Tabs (1.0.1)

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Microsoft-IIS/8.5

# Server API
cgi-fcgi

# PHP Version
5.6.31

# PHP Extensions
bcmath, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, mysqlnd, odbc, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, pdo_sqlsrv, Phar, Reflection, session, SimpleXML, soap, SPL, sqlsrv, standard, tidy, tokenizer, wddx, wincache, xml, xmlreader, xmlrpc, xmlwriter, zip, zlib

# PHP Settings
max_execution_time - 300
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 128M
post_max_size - 8M
sql.safe_mode - Off
upload_max_filesize - 2M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
odbc.max_links - Unlimited
odbc.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pdo_sqlsrv.client_buffer_max_kb_size - 10240
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
wincache.maxfilesize - 256
wincache.ttlmax - 1200

View Replies:
stewblack23 replied on at Permalink Reply
stewblack23
Hey mohamedkhalid

The first thing I would do is change your PHP version from from 5.6 to at least 7.1 that way c5 will run a little better. Then i would see if you have anything weird going on in your .htaccess file. Then turn off all your c5 caching and look at IIS server setting and see if anything looks weird. (I'm not that familiar with IIS so I'm not sure what type of caching it uses. )
mohamedkhalid replied on at Permalink Reply
Hey stewblack23,

Thank you for you reply,

Currently i have two websites on the same domain name.
Example

Main website is
http://xyz.com

Sub website is
http://xyz.com/test/

web.config for xyz.com is below

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<defaultDocument>
<files>
<clear />
<add value="index.php" />
<add value="Default.htm" />
<add value="Default.asp" />
<add value="index.htm" />
<add value="index.html" />
<add value="iisstart.htm" />
<add value="default.aspx" />
</files>
</defaultDocument>
<rewrite>
<rules>
<rule name="Remove index" stopProcessing="true">
<match url=".*" />
<conditions logicalGrouping="MatchAll">
<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
</conditions>
<action type="Rewrite" url="index.php" />
</rule>
<rule name="Redirect to HTTPS" enabled="true" patternSyntax="Wildcard" stopProcessing="true">
<match url="*" />
<conditions logicalGrouping="MatchAny">
<add input="{HTTPS}" pattern="off" />
</conditions>
<action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Found" />
</rule>
</rules>
<!--<outboundRules>
<rule name="Rewrite SVGZ header" preCondition="IsSVGZ" stopProcessing="true">
<match serverVariable="RESPONSE_Content_Encoding" pattern=".*" />
<action type="Rewrite" value="gzip" />
</rule>
<preConditions>
<preCondition name="IsSVGZ">
<add input="{PATH_INFO}" pattern="\.svgz$" />
</preCondition>
</preConditions>
</outboundRules>-->
</rewrite>
<staticContent>
<mimeMap fileExtension=".woff2" mimeType="font/x-woff" />
</staticContent>
<httpErrors errorMode="Detailed" />
<caching>
<profiles>
<add extension=".jpeg" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" />
<add extension=".mp4" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" />
<add extension=".gif" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" />
<add extension=".png" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" />
<add extension=".jpg" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" />
<add extension=".svg" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" />
<add extension=".css" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" />
<add extension=".js" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" />
</profiles>
</caching>
<urlCompression doStaticCompression="true" doDynamicCompression="true" />
</system.webServer>
</configuration>
mnakalay replied on at Permalink Reply
mnakalay
You say pretty URLs are off but it seems you still have the code for pretty URLs in your config (htaccess I guess) That might be responsible for the redirects

Also, any time you disable or enable pretty URLs, it's a good idea to empty the cache