Trouble with cache headers - shows no-cache no matter what

Hello community!

I have a site for a big event that will draw some very heavy traffic in around 10 days.

Setup is as follows:
Hosting is in the US with media temple. Then the www site is accelerated with their "proCDN" product which is basically edgecast CDN.

Trouble is, that the CDN/acceleration is very picky with cache headers.
Images are cached fine but the page is not.

Looking at the headers I get this for the page:

Cache-Control:no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Date:Tue, 31 May 2011 16:50:00 GMT
Expires:Thu, 19 Nov 1981 08:52:00 GMT
Keep-Alive:timeout=5, max=100

Now there's the trouble. C5 outputs no-cache headers. Trouble is that I did enable full page caching but this setting seem to be ignored!

Is there a way I can "reset" the dashboards perception of the setting? Or in the code force a cache setting.
The best scenario will being able to force a cache header on the pages too, so the acceleration in Europe can do it's job. Otherwise it's just a fancy non-caching proxy and doesn't really help..

Any ideas?
C5 version is

View Replies:
Tarraq replied on at Permalink Reply
Poking around I realised that even the forums here have the same cache setting.

Can it be that the full caching actually does not set cache headers to match?
And how can I control the cache headers of the pages?

Either by a plugin or by hacking the code.
Tarraq replied on at Permalink Reply
I'm completely puzzled.
I did a file search of all files in the C5 distribution source code for "no-cache", ignoring case, and the only hit is in /concrete/controllers/login.php

Can someone please tell me where the no-cache header in normal views are coming from?

It's not the server - I have other cms's running in same stack without the same problems - so it has to come from C5 somewhere..
wyso replied on at Permalink Reply