Unable to set group permission to add pages

Permalink 2 users found helpful
Hi,

I'm new to C5. Though I already like it a lot!
I encountered a problem. I have enabled Advanced Permissions and I have made a new group for my client where he just has specific permissions.
In the sitemap I've set the permission to this group to add Sub-Pages so my client can add pages once the website is live.

But when I login on my clients account I can't add/edit any pages in the Sitemap. I am accessing this through the C5 admin top-bar via the second button from the right (Add Pages and Navigate Your Site). When I click on it, the sidebar does appear but this error message is showing: "Access Denied".
I can access it with my admin account though and I can just give my client all of the permissions but then he will defenitely mess things up so that isn't really a possibility, I'm afraid.

So does anyone know how I can fix this problem?
Thanks in advance!


Regards,
Stef

StefSmeers
View Replies: View Best Answer
goodnightfirefly replied on at Permalink Best Answer Reply
goodnightfirefly
You have to give the new group permission to access the sitemap.

Go to Dashboard > System & Settings > Permissions & Access > Task Permissions
StefSmeers replied on at Permalink Reply
StefSmeers
It worked. In the sidebar the sitemap is visible now, but it still doesn't give me the option to add a page?
fatcatsanonymous replied on at Permalink Reply
Hi,
I'm having this issue as well.
In fact, since I activated advanced settings, my group cannot see the sitemap at all anymore though in the permissions they have access to it. The sitemap loading animation shows briefly and then disappears ...
milwaukee replied on at Permalink Reply 4 Attachments
I am evaluating c5 for use in our organization, and I am quickly becoming mired in permissions difficulties.

version: 5.7.5.6

I have enabled advanced permissions
I created an "editors" group and edited their permissions at the home page, and chose to have those propagate to subpages.
I then created user accounts and assigned them to the editor role

Now when I login as ADMIN:
I cannot access Task Permissions (literally the error says "you cannot access task permissions"
I cannot access the dashboard or the sitemap as pages in the tree (after checking "Include system pages in sitemap", those pages do not display in the sitemap.)
I cannot access User Permissions. An apparently incorrect error message displays "you don't have access to Task permissions"

Signing in as editor:
the entire "page / sitemap / drafts" panel at the top right of the toolbar, displays a message "access denied"
No blocks are accessible to Editors. block categories show and nothing else. under the block categories the message "no block types availabe" shows.

this is making it difficult to prepare a presentation on your platform. I have searched through the doucmentation and forums. I am posting this issue here and will post it anywhere else that I can find.

I don't know about everyone else, but I need an answer for this.