uploading images via dashboard

Permalink
I am running the latest version of concrete5. I am building a new site and I can upload small pictures to the site but anything large it comes back with a 500 error.

I have researched it and can only find old info (nothing for the new software)

Any help on this would be great!

Thanks

View Replies:
hutman replied on at Permalink Reply
hutman
Take a look at your server's PHP Error log, this is most likely either a max_execution_time error or a upload_max_filesize error.
prowler9 replied on at Permalink Reply
Even tho it works fine with my other site on the same server?
jasteele12 replied on at Permalink Reply
jasteele12
Easy enough to to take a look at your environment (PHP) info. A server can be setup to use different PHP versions and settings for different domains.

Either way, hutman gave good advice to track it down.
photodoc1 replied on at Permalink Reply
I'm a new user and just getting started. I was able to upload 2 jpgs in December, but nothing since. It doesn't seem to matter how large or small the file is. The files are actually on my server, but Concrete won't access them and it gives me a 500 code error when I upload.
photodoc1 replied on at Permalink Reply
I found this in the error log:

[23-Jan-2017 13:19:43 America/New_York] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3285 bytes) in /home/technica/public_html/conc8/concrete/vendor/imagine/imagine/lib/Imagine/Gd/Image.php on line 602
prowler9 replied on at Permalink Reply
This is what I am getting as the error.

{"error":{"message":"Allowed memory size of 94371840 bytes exhausted (tried to allocate 8489962 bytes)"},"errors":["Allowed memory size of 94371840 bytes exhausted (tried to allocate 8489962 bytes)"]}
jasteele12 replied on at Permalink Reply
jasteele12
The error message is telling you exactly what the problem is.

Your previous message exceeded PHP's setting of 32 MB, now it appears it's been set to 92 MB.

I'd suggest at least 128 MB, here's what it would look like in php.ini (FYI - you might set this differrently through the hosting control panel):

memory_limit=128M

Depending on your site you could even use 256M. Just a guess but it's probably happening trying to create your defined thumbnail sizes from your uploaded images.

Hope that helps,

John